Cut file and paste to desktop

When I cut a file from say the documents folder in a finder window and paste it to the desktop, it always puts it in the upper left hand corner (almost totally off of the screen). This happens on my iMac and MBP running 10.8.4 and does it whether I use keyboard shortcuts, control-click, or edit menu options. It does not act this way when copying the same file and pasting it to the desktop.

edit… just updated to 1.4.19 and it is still behaving in the manner above

Yes, you are right. This is a bug.