El Capitan Finder spinning beachball after uninstalling TotalFinder

Hi all, I have to ask in here out of desperation.

I recently upgraded to El Capitan and disabled TotalFinder under the advice of the TotalFinder popup messge.

Finder worked fine.

Recently I unstalled TotalFinder and that’s when the problem began.

It now takes 5 minutes or more to open a new Finder window. Mounting a .dmg file takes almost as long.

I’ve tried verifying and repairing permissions and deleted finder.plist.

I also created a new user and opening a Finder window is equally bad so it’s not restricted to my user account. Which is more worrying, it probably suggests something is botched at the system level after uninstalling TotalFinder.

Can someone suggest a fix? I’m actually going to try reinstalling TotalFinder to see what happens.

Reinstalled TotalFinder and still getting the spinning beachball when I open a Finder window.

Strange. After uninstalling TotalFinder should be gone.

Please open Console.app. Then force quit Finder.app via CMD+OPT+ESC, and launch Finder.app again. Then watch if you see some messages about TotalFinder injection into Finder when launching new Finder. Also you could look into Activity Monitor.app, filter processes by “Finder” and see if there are any TotalFinder processes hanging around. There should not be any.

A side note: Usually I get Finder.app beach-balling when my Finder setting is set to show “All my Files” when opening new Finder windows. I have tons of files in my system and it gets unbearably slow. Try to change that if it is your case as well.

1 Like

Thanks for your reply, I followed your tip with Console.app and figured it out.

It wasn’t TotalFinder at all: Finder was trying to automount a network share that isn’t there.

Although I don’t know why this caused the Finder spinning beachball only after I uninstalled TotalFinder and not earlier.

Thank you!

1 Like