Finder slow or unresponsive when copying from/to slow medium


Very often I copy large files (>700MB, movies) from my Notebook to volumes mounted from a SMB server. With TotalFinder, the Finder window reacts very slowly or not at all (beachball coming up) for most of the time the copy is in progress; the progress meter takes a long time to actually show something.
I just tried with a USB stick, the behaviour was the same.

If I relaunch Finder (TotalFinder is gone them) and do the same again, Finder is responsive and fast.

If I copy smaller files, e.g. a couple of folders with audio files between 5 and 20MB each, it is better; there are short delays in responses, but overall I can work while the copying is in progress.

I’m running beta versions of OS X 10.9.3 (13D55) an the latest TotalFinder (1.5.38).

Best regards,

Yeap, exactly same thing here, latest beta and 10.9.3. Totally identical behavior!

I wonder if this could be related to “Folders on top”.

Please try to disable “folders on top” in TotalFinder preferences for a while and report back. I can imagine this could be the problem.

I just tried it; same effect, happily spinning beachball…

I disabled “folders on top” and copied a large file to the network folder.
I re-launched Finder and TotalFinder and copied two more files to the network folder.
As soon as I click on a tab, the beachball starts to roll and it takes a long time so switch to the selected tab or the item in the sidebar.

I get something similar copying a file to AFP Time Capsule USB Hard Drives. It fixes disabling Colored Labels or just closing the tab where the file is copying. I had the same problem with xtrafinder, but only with icon view. I used to switch to list view before copying, but it doesn’t work in totalfinder.

I can confirm this the behaviour changes with disabling and enabling colored labels.