BinaryAge

Folders on top does not work

#1

I just updated to Mojave 10.14.4, disabled SIP but can’t seem to get Folders on Top.
This is about the only reason I use TotalFinder; frankly I don’t understand how anyone can work with the Apple default.

I read the Folders on Top which says

However, some users prefer to see folders first and then files regardless of the actual sorting options.

TotalFinder enables this display by toggle of a keyboard shortcut.

Keyboard Shortcuts
Action Shortcut
Folders on Top ⇧⌘;

I sort files by date, so I can see the latest in each Directory, BUT
I tried “Shift ⌘Command ;” and “Control ⌘Command ;” but these seem to have no effect.

#2

Folders on top is built-in starting with Mojave. You don’t need TotalFinder for that. Check the Advanced tab of the Finder preferences.

#4

I sort files by date

#5

You are correct that Finder only sorts folders on top when sorting by Name. We mentioned it here in our docs:

https://totalfinder.binaryage.com/folders-on-top#mark-starting-in-macos-1012-sierra-finder-now-offers-keep-folders

Quite frankly it was too hard for me to reverse-engineer their new code to implement Folders on Top feature in TotalFinder under Mojave.

#6

The linked documentation

However, some users prefer to see folders first and then files regardless of the actual sorting options.

TotalFinder enables this display by toggle of a keyboard shortcut.

would seem to imply the opposite!

#7

Well, I just added that yellow box on top of the page when Sierra came out. That second quote was written 8 years ago[1]. I should go and review that document. Thanks for pointing it out.

[1] https://github.com/binaryage/totalfinder-web/blame/web/folders-on-top.md#L18