BinaryAge

Full screen weirdness with iTerm2

Hey, I’m just setting up a new MacBook Pro for my work machine. One weirdness I can’t seem to get around is going to full screen with iTerm2.

On my personal Mac (both are on OSX 11.2.3), making iTerm2 full screen enlarges it on the existing space, which is how I want it. On the new Mac it creates a new space for the full screen view.

I know it’s a preference somewhere, but stuffed if I can find it. Not sure if it’s in iTerm2, TotalSpaces, OSX, or something else. Any ideas here? It’s driving me nuts!

Hey there, that one is in the iTerm preferences. General → Window Tab → Untick “Native full screen windows”

1 Like

Oh my god, thankyou! That was driving me insane. I owe you a beer :slight_smile: