Grey screen in full screen mode

bug

#1

I can’t immediately reproduce this bug, but I do encounter it multiple times every week. When using TotalFinder in full screen mode and using dual mode, the entire screen will turn grey rendering the Finder window useless. This can be fixed by going to mission control and going back to Finder window which will remove the grey screen.

Attached is a rather dull screenshot illustrating the problem.


#2

This sounds like a pretty annoying thing. I understand technically why this could happen. TotalFinder “glues” Finder windows onto its own frame window which has this gray background. For some reason that repositioning of Finder windows didn’t work.

What is your system version? Ideally open Terminal.app and send me the output of sw_vers.


#3

The output of sw_vers is

ProductName: Mac OS X
ProductVersion: 10.12.4
BuildVersion: 16E195


#4

Good, that’s very close to my current system version. I don’t use fullscreen mode much, but I will try to reproduce it here on my machine.


#5

I’ve noticed that adding files to one of the open folders, will cause Finder to turn grey.

For example:

  • Open dual tab full screen Finder
  • Change to another Desktop
  • Download file/Move file to the folder open in Finder
  • Change back to Finder
  • Grey screen

I hope this can help.

Changing Desktop again and returning to Finder removes the grey screen as well.


#6

Thanks for the repro steps. I was able to reproduce it and I’m on it.


#7

Please test TotalFinder 1.9.4 (pre-release):
https://totalfinder.binaryage.com/beta-changes#1.9.4

The problem should be fixed there.


#8

Thanks, this indeed solves the problem but at first sight introduces a new bug.

When switching to another Desktop, I’m automatically switched back to the full screen Finder window. Disabling When switching to an application, switch to a Space with open windows for the application in the Mission Control settings doesn’t solve this. Runnning defaults write com.apple.Dock workspaces-auto-swoosh -bool NO && killall Dock in the Terminal does solve this problem.


#9

It this still an issue? I wonder how my change could affect the switching behaviour because the only thing I do it to make sure that after spaces switch Finder windows get re-rendered.

Also I wasn’t able to reproduce it here.

I have When switching to an application, switch to a Space with open windows for the application turned on. And Displays have separate spaces turned off.

How do you exactly switch to another Desktop? Via a keyboard shortuct or via expose? Is there any other window present or the desktop is empty? Etc.


#10

This behaviour started after installing version 1.9.4. I encounter the problem when I switch spaces via the gestures on the trackpad. Switching spaces by switching applications in different spaces with alt-tab, thus not reproduce this problem. I’ve tried to illustrate this in the following short clip.

Changing the options via the Terminal or disabling or enabling any of these options doesn’t change this behaviour. Is there anything I can try to analyze this further or is there any other information that I can supply?


#11

I’ve uninstalled TotalFinder with the accompanied tool and installed version 1.9.5. This seems to have solved the problem so far. Thanks for all the help.


#12

This is really strange. v1.9.5 should not have any fixes related to this issue…