How to prevent Finder window from opening at login?

Hello, HUGE fan of Total Finder, a fantastic Finder snap-in. I’ve purchased 6 licenses. That said, the only annoyance I have with Total Finder is that after install everytime I login to my Mac (10.9.2) the Finder window pops open in the middle of my display. I’ve checked the “Hide” option in Users & Groups -> Login Items but it still happens. Anyone found a way to prevent this behavior? I’d sure appreciate that tip. I tried to search for this topic but found no hits.

1 Like

Here it also happens. Not only at login, but also after restarting Finder and launching TotalFinder.
Looks then like this, tabs are missing:

After invoke CMD,CMD to show visor the tabs slide up from behind that “unfinished” window. Then everything works normal.

TotalFinder 1.5.30 on OS X 10.9.2 Mavericks (with BlackDock ;))

There is a hidden tweak. You can disable tabs restoration during TotalFinder launch. In

defaults write TotalFinderDontRestoreTabsState -bool true

To enable it back to default:

defaults write TotalFinderDontRestoreTabsState -bool false

@darwin And the tabs, when will they be restored then? On first trigger of the Visor? Or do I loose the tabs with this option enabled?

With this tweak enabled TotalFinder does not attempt to restore windows and their tabs to the state before last quitting. Visor is included in this mechanism as well.

1 Like

@marc your Visor issue is probably not related to this. It is just a separate issue, that Visor window is not properly initialized after relaunch (but it has proper tabs I guess).

I’m going to fix the problem right now.

1 Like

@marc I wasn’t able to reproduce it. But I have added some code which could prevent it.

This will be included in the next release 1.5.31 (in few hours on beta channel)

@darwin - marc kinda hijacked my thread, I don’t know if this solution is to prevent the Finder popping up whenever I login to my Mac after reboot or to fix his issue…? Please clarify.

@buck​Zor Hi, I thought my issue is your issue. I just added that this not only happened at login but also if I restart Totalfinder. Anyway, my issue was related to the visor window. Yours too?
But if you have problems with left open standard TotalFinder windows, maybe the hidden tweak @darwin pointed to is the right for you.

@darwin Tried 1.5.31 … it happened again. I can reproduce it still with:
restart Finder
launch TotalFinder
wait 3 seconds

And I have an idea, why it is only happening to me: I use an app Cordlessdog Stay. It repositions windows to a saved positon on startup of applications. I think I have to change some settings there if I do not want to reposition the visor on start of Finder.

Sorry for this confusion here.

Hmm, I now tried
restart Finder, launch TotalFinder, wait 3 seconds
without having running. And it still happens. So my theory that was the cause should be wrong.

I have now tested a bit more under MacOS guest account. I found:

visor visible, restart Finder via menu, launch TotalFinder --> issue as in screenshot above

visor hidden, restart Finder via menu, launch TotalFinder --> no issue

I even made 2 terminal cmd lines:

# if we are in terminal visor is auto hidden
osascript -e 'Tell application "Finder" to quit' ; sleep 2 ; open -a TotalFinder
# --> no issue

# next cmd line activates finder first which should show visor
open -a Finder; sleep 2; osascript -e 'Tell application "Finder" to quit' ; sleep 2 ; open -a TotalFinder
# --> issue as in screen shot

One has to wait 5 seconds or so, until the Totalfinder launch has finished its job.

And I found, if you disable the slide animation in settings, the first cli

osascript -e 'Tell application "Finder" to quit' ; sleep 2 ; open -a TotalFinder

also works to produce the issue. Maybe you have to show and hide the visor first, before running that cli.
If I hide the visor by CMD,CMD and then go to Terminal and run that cmd line, then the visor shows up like seen in the screen shot, but then hides again itself after 1 sec or so.
If i hide the visor by just clicking into Terminal, and having the visor auto hide that way, then the cmd line leads to the unfinished visor like in the screenshot and it does not hide after 1 sec.

OSX 10.9.2 TotalFinder 1.5.31

Still don’t know if anyone even read my thread, only response was a thread jack and a developer only responded to the jacker.


Is it possible to not have Finder POP OPEN at login? Anyone?


@buckZor Have you tried disabling restoration of TotalFinder windows? I believe this should fix the problem.

defaults write TotalFinderDontRestoreTabsState -bool true