Keyboard shortcut switches to normal terminal window on second screen after sliding down TT


I use a cinema display with my MacBook and I keep TT living on the cinema display. I often have many terminal windows open on both screen, seperate from the sliding TT window which I use for quick tasks.

E.g. On my macbook screen I have a window showing me htop output so I can monitor a server. On my cinema display i have the sliding TT window which I use to update a git repo on the server.


In the past this all worked exactly as expected, but some time recently (probably Mavericks-related but I’m not sure because it took me awhile to figure out the exact situation) the behavior broke.

Now it seems that whenever I summon TT with the keyboard shortcut it slides down but then immediately the window focus switches to the normal terminal window on my second screen. So when I summon TT and type a command it gets typed into the window on my MacBook not the one on my cinema display.

This is a huge problem as it’s surprising, confusing and could easily lead me to type a command onto a different computer than intended! The sliding TT window is still visible, so I often type for awhile before understanding why it’s not registering (potentially affecting the other window).

The problem doesn’t have any effect if the normal terminal window is on the same display as the TT sliding one, it’s only an issue when the TT is on one display and the normal window is in the other.

Please test this and see if you are affected as well. I’m sure it’s a relatively niche use-case but I think it’s a valid one and it’s very confusing as a user.


I have just tested it here under Mavericks 10.9.3 (beta developer seed). I don’t have external display here while traveling, but I can test it on software-emulated Air Display. I was unable to reproduce it so far.

Just curious what is your Mission Control settings:
I have checked “Displays have separate Spaces”

Sliding TT window should grab focus when sliding is initiated. There must be something else stealing it after TT slides down. Can you please focus on timing and try to type something immediately after you hit the shortcut? Maybe you will see few characters in TT session and then rest in that normal Terminal window. This would mean there is some time window between TT grabs focus and something else steals it.

Thanks for the quick reply!

Just checked and I have the same setting.

I see exactly where you are coming from, but unfortunately I can’t see any evidence for the idea. As soon s the TT comes down on the Cinema Display the window switches to the Terminal on my MacBook, no characters get typed into the TT slider in any of my testing.


Here’s something to note: If focus is already on the normal terminal window on my macbook and I invoke TT then the focus correctly switches to the TT slider. If the focus is on any other window when I invoke TT then it goes to the terminal window on my MacBook. That seems like an important clue and also something that you could use to figure it if you’ve reproduced my issue or not.


Here’s another thing that seems to be causing it: I have my MacBook set as the subordinate display and my Cinema Display set as the dominant one. By this I mean that in the “arrangement” tab of the Displays Preference Pane the menu bar is on the Cinema Display rather than the MacBook. I don’t think this is unusual but it could easily explain why you don’t see the bug when using Air Display (as you’re almost certainly not making your iPad the dominant/menu bar display).

If I move the menu bar onto the MacBook then the problem goes away completely (opening TT slides down the terminal in the MacBook and keeps focus there regardless of terminal windows on the Cinema Display).

Hopefully that will help you reproduce the issue. Thanks for your efforts!