BinaryAge

Latest version for High Sierra?

I’m running High Sierra on an old machine with TS. Now I got the following update dialog:

Is it safe to update TS (staying for the moment on High Sierra)?

Why would you want to update when your version of TS runs clean on High Sierra? Just stick with what works.

Well, I just wanted to check, because TS offers the update to me.

Yeah why would anybody want to upgrade anything.