macOS Big Sur and TotalFinder

I just performed a clean install of Big Sur and was unable to get the latest builds (tried 1.13.7 and 1.13.8) to to work.

However, I then installed 1.13.0 and then 1.13.8 and that time it DID work. the is something important in 1.13.0 that was removed or significantly changed in a later release that is preventing the security override checks from finishing.

1.13.0. up to 1.13.7 were problematic. Are you sure you installed 1.13.8 the first time?
I had several situations when I installed from wrong DMG during testing, because both had “TotalFinder” name. Sometimes DMG opening gets confusing and brings forward a different mounted DMG than you actually clicked.

Yes. With this latest clean install I started with 1.13.8. It seemed to install fine and there was a security override prompt but then TF stalled out. The process was still running but there was still an error related to system events. I made several attempts at installing 1.13.8 and 1.13.7 but couldn’t get TF to work with either on a clean install. I then installed 1.13.0 over 1.13.8 and it just worked. After that I reinstalled 1.13.8 and it still worked.

Finally I get TF 1.13.8 to work on Big Sur. The problem was if you set this in System Preferences -> General

Instead of this

TF generates the problems mentioned in the previous message


Just updated to macOS Big Sur and new Total Finder. It installed flawlessly. Thank you :slight_smile:
I can’t work without labels - simple but effective for organising my folders and files.
Stay safe.


Just got the new MacBook Pro 13" with the M1 processor. It upgraded to Big Sur 11.0.1. I did everything I was supposed to do in terms of disabling SIP via the recovery console (which, by the way is a different process to get to versus Intel processor Macs) as well as the command line.

1.13.8 is NOT working. Total Finder appears to install ok but I am not seeing it in the Finder menu at all and none of the features work. Maybe this has to do with 11.0.1 versus 11.0? Does anyone here have the same setup and experiencing the same issues?

It’s not working because TotalFinder doesn’t work on M1 machines and it sounds like you’re using one.

Yes I certainly am. Are there any plans to make TF work with M1 Macs?

Yes, I’m waiting for my M1 MacBook to be delivered.

1 Like

@darwin, you truly are an amazing developer! Thank you for your dedication and willingness to upgrade, enhance and improve your products. Its why I recommend your stuff to everyone I work with.

1 Like

It could be great if the TF installer package could change this setting automatically to help improving the user experience

@darwin First of all I wanted to say thank you SO MUCH once again for your willingness to continue developing this product which has a real dedicated and passionate fan base. TotalFinder is really so integral to my MacOS experience and I am incredibly glad that you will continue supporting it.

I just wanted to check in if you are aware of any graphics glitches that can occur in the Tab view? I haven’t tested this extensively but it seems to be caused when Visor is being used in combination with narrow Tab view. Anyone else ever ran into this? I’m on MacOS Catalina 10.15.7.

I am I just started switching the OS mode to dark mode today and noticed that when Big Sur made a switch from Light Mode to Dark Mode WITH Total Finder running, the switch killed Total Finder. I had to restart it manually after the switch to Dark Mode.

Not sure if you were aware.

Just discovered:

When opening a .dmg file with an App to copy AND open a second tab in Total Finder to copy to,
NOW when doing a double click on one of this TAB’s to combine the TAB’s, Total Finder crashes and restarts, what takes 3-6 seconds.
When it opens up again he still got both tabs open but they are still not combined TAB’s.

Hope that helps!

Hello everyone!

Currently running TF 1.13.8 on freshly upgraded Big Sur.

Noticed a bug with VISOR:

To replicate Bug:

  1. launch TF
  2. open a second tab by clicking on the open tab button with your mouse
  3. join tabs (dual pane) by double clicking on the on one of the two. After a short moment the ‘long/joined tab appears’.
  4. close the joint tab by clicking the clicking the close tab icon on the joint tab itself. TF closes.
  5. Relaunch TF : you can only see a large grey mostly unresponsive surface (no windows).
  6. In order to reset TF, you have to relaunch Finder and relaunch TF

The issue does not occur if you launch double pane with cmd + U

Any ideas?


Giacomo Bruzzo

Since Big Sur 11.2 and TF 1.13.8 the tabs are behaving strange.
When combining two taps only one shown (not the combinend tab shown) or one big tab with the two names of the folders in only one side of the big tab or when terminating one of the combined tabs, you’ll end up with 3 tabs… etc.

PLUS the old unfixed one:
When opening a .dmg file AND open a second tab in Total Finder to copy to,
NOW when doing a double click on one of this TAB’s to combine the TAB’s, Total Finder crashes and restarts, what takes 3-6 seconds.
When it opens up again he still got both tabs open but they are still not combined TAB’s.

Big Sur 11.2 and TF 1.13.9
Two open combined TAB’s. Then you close one by clicking the ‘x’ and both tabs are gone what results in TF window disappearing.

1 Like

The issues should be addressedin TotalFinder 1.13.10:

@Nurb_2Kea thanks for reporting!

1 Like

Hi, thanks the combining tabs work for usual tabs now, BUT the main problem was the crash :

The old unfixed one (see one comment above from my last):

When having an open Finder window and opening a .dmg file you’ll get two tabs. When you try to combine these tabs to copy or so, TF still crashes the first time. The second time you try to combine after the crash it works.
When it opens up after the crash TF still got both tabs open but they are still not combined TAB’s.
Just after the second try to combine them, it works.

And it continues over again when opening another .dmg file and want to combine it.

Have a try with any .dmg file and try to combine.

(I de-/re-installed TF just to make sure it’s nothing else)

It seems to be connected with the General-Setting “Prefer tabs:” in Big Surs System Preferences, which I change from “always” to “never”.

After that, my Tab-issue seems to be gone…
Since I found out just this afternoon, it will take a couple of days to verify the results.

just saw that @Carolina also mentioned that in November 2020… :man_facepalming:

1 Like