Mission control issues/spaces rearrangement glitch

Hello.

Love totalspaces2 fantastic app.

I have one problem: When I enter mission control using four finger swipe up all is good and when I exit it using four finger swipe down it is fine as well.

The problem manifests when I am within mission control and click and drag a space to rearrange the order of spaces. It hangs and icons that appear under applications that are disperse during mission control remain permanent even after it unsticks. When I have moved a space and then try to exit mission control using four finger swipe down, I get a blurred screen (like the background in mission control and the interface become frozen for about 10 seconds.

This is on a retina macbook pro late 2014 running yosemite 10.10.5

I know this may be unclear, I am totally willing to film and post this behaviour.

Thanks,
Z

Hey Z,

Interesting. Haven’t had any other reports of this.

  1. Yes a video would be great.

  2. Does this happen as well if you re-arrange Spaces in TotalSpaces “Overview grid”? I’m assuming when you say “Mission Control” you mean OS X’s default view of Spaces, and not TotalSpaces “Overview grid”.

  3. Do you also have 4 finger swipe gestures enabled in TotalSpaces?

  4. Would you mind reproducing the issue, then see if there’s more information in the Console:
    http://binaryage.clarify-it.com/d/meeryk

  5. Does your MacBook Pro have the two video cards? If you’re not sure, please launch “System Information” in Spotlight and look here: http://d.pr/i/btU1

Steve

  1. I will work on filming a video of this right now.

  2. I just tried the totalspaces overview grid and it does not happen. Only in the mission control interface of os x.

  3. If you mean to switch from one space to another: the answer is yes I do. (the: “Swipe to change space” option is set to “4 fingers”.

4)I will work on this right now as well.

  1. It has intel iris, whatever that means. Here is a picture of the requested page: system info graphics page

You can also see in the picture linked above one of the sticking icons as mentioned previously.

Thank you so much for the super fast response!
Z

Ok so I have made a video which can be seen here: https://vid.me/DmVj

The console is giving me a whole lot of these items these items(when producing above video)(sorry I am not the best with these deep computing type things… tell me if there is a better way of outputting the info) I tried to select what seems of interest: http://d.pr/n/YZVD

Thanks for the video, logs, and responses. From the logs, I can tell you have a lot of system mods installed. At least Flavours, SIMBL, TotalSpaces. Would you mind sharing what files are in in your /Library/ScriptingAdditions?

First step is to determine if TotalSpaces is the source of the issue, so please quit TotalSpaces and see if the issue still exists.

If the issue does exist, then something else is causing it.

If the issue does not exist, then please restart TotalSpaces and see if the issue manifests on the first try, or let me know if the issue doesn’t happen, but eventually appears over time.

Let me know what you find.

Here is an image of the contents of my /Library/ScriptingAdditions folder: http://i.imgur.com/6txxajS.png

Upon quitting totalspaces the problem disappears. When running absolutely no other mods or application (other than the ones used to observe the problem such as mail or calendar) and totalspaces the problem occurs on the first attempt. When totalspaces is quit, the first try becomes functional once again. Upon restarting, once again the problem manifests on the first try.

Than you so much for looking into this!
Z

This is all good info, thanks. I haven’t reproduced the issue yet, so I still think it might be an interaction between TotalSpaces and perhaps another one of those ScriptingAdditions. It could also be a systemic issue, which usually requires re-installing either the latest Combo Update or the whole OS. Hopefully that’s not required.

I’ll keep digging and let you know. I don’t have the exact same MBP, so hopefully it’s not somehow hardware related =P
Stay tuned.

OK, thanks!

Looking forward to any progress on this problem…

Z

We have a theory that the Dock is crashing. If we can get those crash reports, they might provide us more info about the issue:

  1. In Finder, hold the Option (alt) key and choose the “Go > Library” from the Finder menu.
  2. Go into the Logs folder.
  3. Go into the DiagnosticReports folder.
  4. Send any files that start with “Dock” or “TotalSpaces” to support@binaryage.com

Email sent!

You guys/gals seem very efficient! Good luck with the logs.

I wish I could be of more assistance…

Z

I’m curious, are you in a position to install and try version 2.3.6 of TotalSpaces to see if the issue also exists?

Ok so I have just tried using 2.3.6 and I get the exact same behaviour.

Z

Hello !

I ran into the same issue but only when the option “Displays have separate spaces” is unchecked>

I have just tested:

  • When checked, I can re-arrange the desktop order without issues
  • When unchecked, the mess happens.

Hope it helps :slight_smile:

Mac OS 10.10.5
Retina display 13" Early 2015
TotalSpace2: 2.3.9

Can you confirm whether you’re using an external monitor or multiple monitors perhaps.

Was using an external monitor, but the same issue existed using the laptop display.

I gave up on el capitan entirely, back on mavericks now and everything is perfect.

Thanks.

I can confirm similar setup:

  • Displays have separate spaces: unchecked
  • MBP 2011 10.11.6 + external monitor

Related:


Please fix this - I’ve ended up completely avoiding Mission Control due to this.

any updates on this for any of you?

I am literally using mavericks as a work around to this problem and would kind of like to upgrade.

Thanks.

I’m delighted to report v2.49 appears to have fixed this issue for me. Many thanks to @stephen and @BinarySteve.

Fantastic news!

Please do tell what OS you are using?

Thanks.

Still on same setup: