New Folder action in 1.8.1 gives same name as random existing folder or file in same directory

bug
el-capitan
yosemite
mavericks

#1

Since installing the update to 1.8.1, I’ve seen an odd behavior that when creating a new folder, instead of being called “untitled folder” ready to be renamed, the new folder looks like a duplicate of any other folder within the same directory, and sometime a dupe of a single file in the directory.

In this example, the new “untitled folder” showed up as a dupe to the “Apple RK” file. Any ideas?


Folder shown twice after extraction
#2

Odd. Doesn`t happen to me.


#3

I should have mentioned I’m still on 10.11.6 El Capitan, and it occurs on both my 2014 Mac Mini and 2014 iMac.

Odd indeed!


#4

I’m having the same problem. It just started with my last TotalFinder update to 1.8.1


#5

Same here, only since the latest update.


#6

The same behavior when copying a file from one pane to another. Running 10.11.6 El Capitan on a Mac mini (Late 2012).


#7

I have the same issue on 10.11.6 on MBP (mid 2012).

Any idea when this might be fixed?


#8

SOLUTION FOUND!
I had the same problem but I fixed it by downgrading to 1.7.12 . this bug is related to “Folders On Top” option so you can alternatively disable it instead of downgrading.
you can download older versions from here :
http://totalfinder.binaryage.com/beta-changes#latest


#9

Awesome, thanks! I’ve downloaded it and will see if it works for me. The bug hasn’t seemed to affect me much over the last few weeks, but I’ll certainly downgrade if it pops up again and gets annoying.


#10

Today I’ve found another problem with my totalfinder (version 1.7.12) , it is poor in performance when I browse the folders change tabs. some dude advice me to downgrade to (1.7.10) and it solved that problem. it seems like folks at binaryage don’t give a shit to solve such problems


#11

Same problem here for months. On MB late 2009 as well as MBP 2015. Have to change folder or tab and then go back in order for new folder to be named correctly. Happens to me sometimes as well when cut&paste files.
@darwin do you know if anyone is looking into this yet?
Thanks


#12

Good day. This problem still persists with newest TF release 1.9 on my MBP 2009. If I disable folders on top, everything is fine. OK, quickly hitting CMD+Shift+M resolves it, but still … annoying.


#13

What does CMD+Shift+M do?


#14

It triggers “folders-on-top”. So, after creating new files and folders, it helps to disable/enable folders on top with this key combo. After that, all is displayed correctly.


#15

Ah, gotcha. Thanks for the info. Oddly, it’s Shift+CMD+; for me, but it does work!


#16

I agree that this is super-annoying but I didn’t find a reliable solution.

Finder internally uses item’s number to bring an item into editing state. The problem is that when TotalFinder sorts the view with Folders on Top that number might no longer point to the correct item => confusion.