No-Bundle error display

Hi … When adding the SheepShaver app in a specific desktop I got the result you can see at the link below. What does that mean ?

Sorry I can’t see the dropbox file for some reason - perhaps you can make a new link?

Sorry … You can now see the image in the thread.

Ok thanks. It looks like we can’t find the correct bundle information.

Perhaps you could try removing that row in Apps preferences, and adding the app to the desktop using OSX’s normal mechanism - control-click on the icon in the Dock and choose Options -> Assign To: This Desktop.

Here’s what it looks like for me - I have my dock on the right.

If you do that, I’d be interested to know if it a) works, and b) what it shows in the Apps prefs in TotalSpaces.

While other apps display the «Options» sub-menu like you showed me, this app does not show any.
See this link:

This app is SheepShaver, a Mac OS 9 emulator that run natively in OS X. If I understand what is the problem, maybe the developper can be of help.

By the way … I am having difficulty displaying a hiden link in your message browser. If I add this link … I see the link under my text but nothing on the preview side neither the link nor the image. The only way I found is to simply paste the link. See the display of the message when I am writing it:

It looks like it’s not possible. I don’t immediately know why, but it may be that the bundle id is missing for some reason - perhaps you could send that screenshot to the developer of sheep shaver, they may know why it’s like that.

I’ve sent a screenshot and a request to the developer. He added a «creator code», but the problem persists. Why is your software is displaying «no-bundle» ? What’s missing that triggers that display ?

It means it can’t find the CFBundleIdentifier - so I’m guessing there is something amiss with the application’s Info.plist file.