No windows in Overview Grid

New to TotalSpaces - when I go into Overview, the windows open in a given space don’t show. However, they show in the documentation (ie. you can grab a window and move it to another space). Advice?

You just see a bunch of empty spaces when you go to the grid? Something must be wrong. What OS are you on (Lion or Mountain Lion?)

Any chance you can pose a screenshot of the grid? (use shift-cmd-3)

I met this problem yesterday also. can not find any thumbnail in one grid. (mavericks)
I will give a screenshot when I met next time.

Hi! I have the same problem using mavericks. At first everything works as expected, after some time the overview-grid is empty. This happens even if no external display is attached. Background-images are showing up, though. Unfortunately i can’t upload a screenshot (Sorry, there was an error uploading that file. Please try again.).
TotalSpaces2 v2.0.10 (Mavericks)

What version of TotalSpaces are you using?

TotalSpaces2 v2.0.10 (Mavericks)

Just played around a little bit and deactivated the background images (TotalSpaces2 - Preferences - General - Backgrounds in the overview grid -> None). Now my windows are slightly visible but not draggable. Would love to upload a screenshot, but its still the same error msg. I have a lot of applications pinned to a specific desktop and some on every desktop.

I’m sorry I don’t know what’s wrong with the uploading - is there somewhere else you could share it with me? (eg dropbox or similar?)

It sounds like the layers on the overview grid are getting in the wrong order. But I don’t know how that could happen at the moment. You can reset the overview grid by adding and then removing a column in TotalSpaces Layout prefs. (Or by restarting TotalSpaces).

i upoaded the screenshot:
after restarting totalSpaces. it works again, but it always does for some time…


Do you have any idea what might trigger the issue?

As I suspected, the layers got mixed up - if only I could reproduce it I could fix it.

Possibly there is some specific thing - such as dragging a window, using exposé, or some such circumstance that causes the backgrounds to show in front of the windows the next time the overview grid is shown.

i do not really know how to reproduce it, but it happens after a few minutes of using my macbook. But the layers get messed up only after visiting a space. So at first only the current space is messed up. All the other spaces are shown correctly. After visiting another space those layers are mixed up, too. (Screenshot before visiting the other spaces: I deactivated automatic graphics switching, it does not mather if i put my macBook to sleep or not, i just happens after a few minutes (~20min)

I’ve been seeing this as well. TotalSpaces 2.0.11 on Mavericks 10.9.1.

Changing the “Backgrounds in the overview grid” to a new setting seems to make everything reappear (i.e. I do not need to restart TotalSpaces), but then over time windows start disappearing in the overview grid again.

It appears to happen in one space at a time. At some point, space X loses its windows. Then a few minutes later another space goes, and so forth, until I either change the “backgrounds in the overview grid” setting again, or restart TotalSpaces. The disappearances do appear to be by-space rather than by-window. If I move a window from a space that is still showing its windows to a space where the windows have gone, the window disappears. If I move it back to the original space, the window reappears.

I haven’t yet been able to determine something specific that triggers it. Although I’m almost positive that you have to have switched to the space at least once recently in order to get that space to lose its overview windows. I’ll post if I’m able to figure something out.

Now that I’ve experimented some more, I think it may be related (in my case at least) to the background picture changing. My desktop backgrounds are set to change every hour or so. When one does, there’s sometimes a short period of time when the TS overview shows the “old” image for that space (as if it hasn’t yet “noticed” the change). Then, once the TS overview does update that space’s background to the new image, it looks like that may be when the windows disappear for that space, as if the new image is being drawn in the wrong layer. Hope this helps.

Hi, that may help, thanks. I will investigate the code that handles this.

Hello. I am so happy to know this is a fresh topic as there might be some hope in fixing. I just purchased TotalSpaces in hopes it would remedy the situation but it did not. It didn’t do this initially when I had downloaded the trial version for the first couple days and then it started. I think dazuma has hit a nail on the head with this one. I too have rotating background images but when turned off (made static) it doesn’t seem to help any.

I did a restart of my computer after changing each desktop to not rotate images and voila! It works perfect. When i then went to a specific desktop and changed it to rotate, I could no longer see the windows/programs that were open while in grid view for that desktop. And if it was drug to a desktop that had rotate off, I still could not see it. However, if I opened a window/program from a desktop with the rotate off, you could see them in grid mode but still not if it was drug to a desktop/space with rotate enabled.

Sorry to sound so repetitive, but just trying to be as specific as possible for you. Thanks for your help! Really, really love that there is a product like this and very much appreciate your efforts it making and tweaking it!

Hello, Thanks for the detailed description.

I wonder if you could try this version:

It’s the latest pre-release. It may help - I can’t reproduce the problem with this version.

Unfortuately, it still seems to be doing it. Double checked the version to make sure it installed correctly and it is saying 2.0.15. Another thing I noted in testing more is that it’s not necessarily rotating the desktop pictures feature as it has to do with simply changing the desktop picture for that particular desktop.

Thanks again for looking into this!

Hi, aha… I’ve just discovered the root cause. Thanks for your feedback… I’ll have an updated version for you shortly.

Please try this:

There was a different code path if “Displays have separate spaces” was unchecked in Mission Control prefs - this is the reason I was not able to reproduce this before now.

Good news! The 2.0.16 build appears to fix the issue for me. Thanks!

WOW!! This is really great! Thank you so much! =)