Output screen remain the same, does not switch by desktop

Don’t know it only happen in Yosemite or all other mac os versions.
But I have output screen (secondary screen) and switching around different desktops.
Mac’s screen works fine, but output screen just keep the same one.
How do I make totalspace works on output screen?

I might be wrong, but it sounds like just how multi-display works in Maverick and Yosemite.
Each display has it own set of desktops. Thus, switching desktops on display 1 doesn’t change the desktop on display 2.
Activate Mission Control. How many desktops are displayed on each monitor. I suspect your 2nd monitor has only 1 desktop on it.

You can make them use one desktop across both displays by un-checking “Displays have separate Spaces” in the Mission Control preferences, or you can check “Sync Grids” in TotalSpaces 2 preferences. If you don’t see this in TotalSpaces, make sure you have the most recent version 2.2.9 from http://totalspaces.binaryage.com/changes2.

Personally I like having the monitors work separately. I can easily monitor activity like copying one the 2nd monitor, while changing desktops on the 1st.

Hope this helps.

Hi I solved this by using “another” total space on secondary desktop.
Just like you said Yosemite treat each desktop as different desktop.
Unlike older Mac OS version, I need to use software like “secondary top bar”.