BinaryAge

Parallels and Total Spaces

When I launch a Parallels virtual machine (VM) with MacOS, the VM takes over the CMD-Tab and CTRL+arrow commands, basically deactivating TotalSpaces on my system. This does not happen when I use VMWare Fusion. Is there a setting in either TotalSpaces or Parallels to get VMs in Parallels to behave in the same way as VMs in Fusion?

Interesting! I’ve been having bizarre troubles with TotalSpaces becoming unresponsive to keyboard commands, and hadn’t thought to connect it to Parallels, which I run intermittently.

Won’t have time to come back to this for a while, but a possible fix: if you can figure out the menu mappings to keyboard commands in either app, you can change them in System Preferences > Keyboard > Shortcuts > App Shortcuts. If that doesn’t work, as Plan B I would set up a launcher app (I use Quicksilver, but there are plenty) to intercept Command-Tab and Control-Arrows to run scripts, and then have the scripts do different things depending on whether Parallels is running and/or frontmost. (AppleScript can target keys to particular applications.)