Problems resizing windows with TotalSpaces2 on OS X 10.9

TotalSpaces2 crashed twice during the initial setup and config process, which I can live with, but when I try to re-size windows, they jump around and re-position themselves, so I can’t make them the size I want, or put them in the location I want. This happened with both Terminal and Chrome windows. This behavior went away when I shut down TotalSpaces2.

I am still in the eval period, so this will keep me from buying TotalSpaces2, as I can’t work with this bug. Thanks.

Hi, we would very much like to get crash reports if you see a crash again so we can fix them.

The repositioning of windows - that sounds very strange - is this when you are moving windows around on your desktop normally? Or when you are using the TotalSpaces2 overview grid?

Regarding a crash report, TotalSpaces just “disappeared”, and I didn’t notice that it died until I tried to move to another space. If there’s a way to find a crash report I’ll be glad to do so.

The window resizing problem sounds a little like this old post:

It would happen within a space when I was resizing an application window. In one case I had a Terminal window open, and each time I tried to re-size it by dragging the lower-right corner, the left side of the Terminal window would jump to a certain position on screen, and the Terminal would re-size to some height/width that I didn’t choose. (The upper-left corner of the window may have jumped to a specific x/y coordinate; I didn’t pay attention to the vertical location.) The same thing happened with Chrome. I’m pretty sure it always jumped to the same horizontal position.

This happened on OS X 10.9 with a new MacBook Pro.

I just did some more experiments with the re-sizing problem, because I’d really like to be able to use your software.

The problems don’t start right away, but once they start, the Terminal window always jumps back to a position so its upper-left corner is 259 or 260 pixels from the left border, and 70 pixels down from the menu bar.

Unfortunately Safari jumps around differently. I didn’t measure its x-position, but it always jumps back to the top, so it’s directly under the menu bar. Firefox behaves like this also.

When I say that it jumps around, I mean that it jumps to those positions whenever I try to resize the windows, either by dragging the right side of the window, the bottom of the window, or the bottom right corner.

Sorry for all the posts, but one way to repeat this is to open a Terminal window with TotalSpaces2 started, then make the Terminal full screen. Then reduce it back to its normal size, move the Terminal to the far left of the current Space, then re-size it a few times. It doesn’t start jumping around immediately, but after re-sizing it and moving it just a few times, it quickly begins jumping back to the same x/y position each time you re-size it.

The x/y position isn’t always the same as what I reported in the previous comment, but once it starts jumping to a certain position, it always jump back to that same position.

I don’t normally make windows full-screen, so I don’t think I did this before. I was just looking for a way to exercise TotalSpaces2 and make the problem repeatable, and discovered this.

This is inexplicable, at least at the moment. The reason being, TotalSpaces has nothing to do with window resizing - that’s done by the windows server. I can’t think of any mechanism that this could happen. (And I’ve tried to repeat it, but without success).

My guess is that there is something affecting, or conflicting with TotalSpaces somehow. (Just to make certain - you are sure that this only happens when TotalSpaces is running?)

Do you have any other software installed such as a window manager (eg sizeup or similar)?

Can you check the contents of the folder


(Use the Go->Go to folder menu in Finder)

There should at least be TotalSpaces.osax in there, is there anything else?

I apologize, after a couple of reboots, this seems to happen with and without TotalSpaces2 running. With TotalSpaces2 running after a reboot, this problem happens very quickly, but without it running, I have to exercise the Terminal window quite a bit more before the problem begins to happen.

For completeness, to answer your other questions, I don’t have any other window managers running, and TotalSpaces.osax is the only file in that folder.

Again, I apologize; I just never saw the problem without TotalSpaces2 running. I’ll report this to Apple.

No problem, I hope you can find a way to get it fixed.
I wonder if it could even be a hardware problem? (meaning the mouse jumping position somehow).

Good point. I’ve only tried it with the trackpad so far. I’ll use a mouse and see how that works. Thank you.