Problems under El Capitabn

Trying to get TotalSpaces to work under the release version of EC (10.11), without much joy so far. I have set the SIP level to 03 and 67 but TS still complains about needing to set the SIP level. TS is way too useful to me to give up easily. Has anyone got it to work?

Oh, and I got XtraFinder working using the SIP utility so it would seem not to be a problem with what I’m doing…


I assume by TotalSpaces you actually mean TotalFinder. And I assume that you are using hackintosh because referencing numeric levels. Under hackintosh the bit #2 has to be set for TotalFinder to work. One user reported 7 worked, which is bits 0, 1 and 2 set.

No. I meant Total Spaces and mentioned XtraFinder because I saw someone note that XtraFinder has the same, or a similar problem under EC.

In fact I tried to set the SIP value from the recovery volume but it didn’t survive a reboot hence my using the SIPUility. Yes, I’m using a Hackintosh, sorry I forgot to mention it - oops.

Is there anything I can do?

TotalSpaces has the same requirement as TotalFinder. Set SIPUtility to write there number 7. It should work after restart.

Alas not. I tried disabling all options and still didn’t work. Not to worry, a solution will become clear or it won’t. I appreciate the help though, Thanks.

1 Like

Had a few moments to spare so I thought I’d revisit the TotalSpaces problem. It turns out there’s an option in the Clover bootloader config.plist which configures the SIP status. I re-read your comment above and changed the value from 0x3 to 0x7. Worked first time. Now I have TotalSpaces back. Yay!

I know that being a Hackintosh it isn’t in the mainstream, but I thought I’d report back FWIW. In case it’s helpful for someone else.

Time for a coffee.


1 Like