BinaryAge

Really weird hotkey stacking/delay/capturing issues :(


#1

Hey, I love TotalSpaces, but something really weird has been happening lately. I have cmd + 1, cmd + 2, cmd + 3, cmd + 4 assigned to quick-switch to spaces. It’ll be working normally, then after a while (not sure what triggers it), i’ll press a hotkey, and it won’t switch. Then I’ll press it 2 times, and it’ll switch. Then the next switch sometimes takes 3 presses. Then the next switch sometimes requires me to press cmd + num 3-4 times. It just keeps stacking up and getting worse.

The weird thing is that TotalSpaces seems to “catch up” at some point, and then execute all the buffered switches. So, when I’m having this issue, if I press cmd + 2 (for example) 10 times straight, it will switch on the 10th press. But if I click the icon for an app on the desktop I’m going to manually, it’ll go to that desktop then switch back to the one I’m on quickly. Then again, and if I keep doing it, it’ll burn through the stack/buffer of delayed hotkeys, and then it works as expected again.

Quitting and re-opening TotalSpaces resets this broken ‘buffer’/stack, but it quickly starts again, and becomes frustrating to use. I’ve also tried reinstalling, to no success.

I’ve tried closing every application open, and it does seem to happen less, but it still happens even I have only 1-2 applications open, no matter what they are.

Any idea what’s going on or how to debug this? It only happens on my laptop, and my desktop is set up identically but isn’t running into this issue. I’ve tried lots of things but can’t figure this one out :frowning:

Thank you.


#2

I’ve seen TotalSpaces do this very occasionally during test and development. I’ve never been able to figure out exactly what happens to make the space switches stack like that (otherwise we would have fixed it!).

One thing that can certainly make strange things happen is if you happen to have other things also mapped to those hotkeys.- for instance Mission Control actions like change space. Check in System Preferences->Keyboard->Shortcuts->Mission Control to confirm that this isn’t the case.

So check that, and I’ll have a look at the code and see if I can figure out where the issue might be.


#3

Thanks for the quick response. I checked my hotkeys and don’t have anything else mapped to those hotkeys, including anything in mission control.

Let me know if you’d like me to test anything else, I still don’t know the exact repro steps but it happens pretty consistently so it’s not too hard to test things once it gets in that state.


#4

I have some info to contribute to this issue because I think it’s happening to me too.

I use totalspaces to have a 3x3 grid of desktops. I use ctrl+arrow keys to navigate them. I notice that when my system is under high cpu usage and memory consumption that the transitions are delayed and inaccurate. For example sometimes i will attempt to move up then left twice but one or more of the lefts get lost until I try to move again.

I dont mind the lag of the transition because the system is under heavy stress, it’s the accuracy that throws me off. I’ve had this issue for as long as I’ve had totalspaces.


#5

Useful thanks, I will look at this again.


#6

I think the root of this problem may be due to window focus when moving between desktops.

For example if I am in space 1 and i want to move two spaces to the right to get to space 4 I have to go through space 2 and 3 when technically I only need to jump from space 1 to space 4 without bringing any of the windows on those other desktops to focus. It feels like by the time i got to space 4 some window in space 3 finally got focus and i am forced back there.

I guess what I want is to be able to navigate my spaces without activating any until i’ve landed on the right one.