"Show in Finder" not working in El Capitan

bug
ghost

#1

Hi

I am running OS X 10.11.1 and TotalFinder 1.7.8 and I am having issue with the “Show in Finder” function. If I right-click a file in some applications (for instance Xcode) and choose “Show in Finder” it doesn’t open the location of the file. In stead it only opens a new tab with the root folder of my disk.
PS: If I download a file in Chrome and choose “Show in Finder” it works correctly.


#2

I have the same issue. If I Restart Finder (without TotalFinder), “Show in Finder” works. But with TotalFinder running, that stops at my user home directory.

This applies to other apps that attempt to open a finder window to a certain folder.


#3

It turns out there’s another thread with this same issue. In that thread, it says version 1.7.9 fixes this issue.

I did an update with Include Pre-releases, and got version 1.7.10. After installing, I see finder go the correct subfolder, then jump back to my home folder.

Turning off “Folders on Top” fixes the issue.


#4

Thanks for the reply erwin, I must have missed the other thread.
I just installed the 1.7.10 pre-release and for me it seems to have fixed the issue, even though I also have “Folders on Top” enabled.


#5

Or not. The problem just came back again.


#6

I have a similar issue. “Show in Finder” opens a new total finder window in which is stuck. Nothing functions in the window.
Is there any solution?


#7

Are you running the latest version 1.7.12 under El Capitan?
Which program did originate the “show in finder” request?


#8

Running the latest version under ElCapitan. The “show in finder” request originated from Safari.


#9

For our own testing, can you tell me how to initiate a “show in finder” request from Safari?


#10

I have the same problem when I press “show in finder” from Safari or Skype and etc.
Latest version 1.8.0


#11

The same problem on 1.8.1


#12

Hi,
I have the same problem on El Captain. I hav the problem also in chrome if I download some file and press “show on finder” I get an damaged window.

Cheers


#13

Good news! This annoying “ghost window” bug should be fixed in TotalFinder 1.9.2 (beta):
https://totalfinder.binaryage.com/beta-changes#1.9.2


#14

Problem is back in ver 1.9.6. When I click on “show in finder” or I type cmd-R, Miscrosoft Word opens. Very annoying. Problem goes away if I disable Total Finder. I am using Sierra.


#15

Problem remains in ver 1.10.2.