Spaces frozen on Mavericks

Hi, it’s the 3rd time this happen to me, I would like to know if this happens to you too.

I use 6 desktops and the “Spaces View”, once in a while gets frozen with the 6 desktop grid on the screen and leaving no other choice than rebooting the system and loosing my work.
How annoying is that? I cannot afford this to happen again and had to stop using TotalSpaces2, although I paid the 1.x (that worked great) and this upgrade to the version 2.

Hi, I am very concerned to hear this. Freezing is the worst thing.

We do have one other report of freezing in certain circumstances, and I am trying to figure out what code path could cause this. I can’t reproduce the problem, so we have to rely on reports.

One important note - TotalSpaces has a mechanism that causes the grid to be cancelled on wake from sleep. If the grid is frozen, putting the machine to sleep then waking it (which should be a quick thing to do with the power button) should get rid of the grid if all else fails.

Another clue for me, is if the Overview Grid hotkey is able to cancel the grid. If clicking the a space on the grid does not work, but using the hotkey does then I know better where to look.

Hi Stephen,
thanks for your feedback. I’ll try to give you more details to see if you are able to reproduce the problem.
I am using TotalSpaces2 v2.0.10 (Mavericks) on a MacBook Pro Mid 2010 (8G Ram, SSD Disk) and I have a external monitor attached.
My grid is composed by 6 desktops. I never used the hotkey for the Overview Grid, I use hot corners, the top right one.
When freezing happens, the mouse keeps working and I am also able to open the force quit window that however does not help (tried to restart Finder for instance). I also tried to unplug the monitor but the Overview Grid is transferred to the macbook monitor and still frozen.

About your important note on the wake from sleep. I thought you should have this mechanism (I’m a developer too) and when the freezing happened i did put my Macbook Pro on sleep, (with the keyboard of course) but when i woke it up is still showing my the Overview Grid!

Hope this helps, let me know if you have other questions that can help you but I cannot reuse TotalSpaces2 until this is fixed as I risk again to loose my work.

I signed up for the forums SPECIFICALLY BECAUSE I have this problem. It is a bit annoying that I can’t just terminate that through ctrl-alt-escape, even though I can kill everything else. I’ve had to turn off that feature because of how annoying that one thing is.

I have 6 workspaces, no zoom animation and no backgrounds for the grid.

I’m using a 2009 iMac with the following basic specs:

  • Processor: 2.66 GHz Intel Core 2 Duo
  • Memory: 4 GB 1067 MHz DDR3
  • Graphics: NVIDIA GeForce 9400 256 MB

I’m a few days into the trial, and TotalSpaces2 is a little laggy in general so far (millisecond delays here and there), but other than this bug is perfectly fine. I should note that RAM IS getting a little taxed here: something else on the system seems to be hogging the RAM more than it did in Snow Leopard, so it might be an error caused by a lack of RAM. I think it’s been happening when I’ve been doing high-toll operations.

I should note that I don’t think m_assante mentioned this: the whole displaying of the grid-view freezes: the mouse moves, but the grid does not respond at all. Basically, you go to the grid, click on a space, and it lights up, but then instead of zooming in on it, it just freezes right there. I’ve left it overnight like that with no response.

Last time it happened, I was copying a large program from the DMG-mount to the App folder. I just tried to run that app, and it encountered an error, which re-installing it from the DMG fixed, which leads me to believe that it also affects file-moving, as I gave it more than enough time to move that file.

Wish I could give you more info on the problem, but it cuts off access to system monitors and developer tools, so I can’t check its status or anything. Hope you guys can identify the problem and get this fixed, 'cause I really do hate what Mac’s done with replacing workspaces with “Mission Control”…

Edit: If you want, I’m willing to try and recreate this bug for you. I’ll just close my programs…
Edit 2: oh, and to answer the question you asked him. I tried hitting a few buttons, including escape, but none of them worked. I didn’t try the hotkey, because I never bothered to learn it (if I’m on grid-view, it means I’m using the mouse and a hot-corner). I should note that holding down the power button DID bring up the shut-down menu, and the screen-saver DID activate after the specified time, but there was no way for me to get out of the frozen grid.

1 Like

Thanks. I’ll try to get an updated version to you as soon as I can. I’ll at least include an alternative mechanism for dismissing the grid that should work in all circumstances.

The one other user I heard from was able to ssh into his machine from another, and execute ‘killall Dock’ - which gets you unstuck, but of course not everyone has this capability. ( restarts automatically)

I thought I’d turned off the hotcorners trigger, but just now my mouse slipped while in Firefox on Facebook, and I ended up accidentally hitting a link and immediately activating the grid through the hotcorner I had there. I immediately tried to click back into the workspace, possibly without letting one of the animations finish, and it froze on me again. Tried the command+space hotkey to open and close it, didn’t work. Hit the power button to sleep and unsleep, didn’t work. Held down the power button and tried to restart. Interesting bit: it stopped trying to shut-down because there’d been an error with Firefox, but I saw in the grid that it had closed. Chrome had been running beneath it with some sort of graphics-heavy app, which was still animating in the little grid square. Tried to restart again and it worked fine.

I just learned that Apple did something which, as a C++ programmer, I think is incredibly stupid, when they made Mavericks. Apparently it purposefully uses the entire RAM to buffer a bunch of crap at all times, leading to a huge amount of unused memory. This of course means that any applications which want to allocate more RAM end up having to wait for it to reorganize that cache before they can get new RAM. It might be ok if you have new RAM sticks, but I still have the 2009 ones. I think this is causing some of my 3D games to have jagged, slow framerates, and may be causing TotalSpaces2 to malfunction: are you calling for new memory to be allocated at any time during the animation processes?

I’m gonna look into that problem with the RAM buffering to see if I might need to change something on the system…

Anything in the log from when you tried to dismiss the grid?

Sorry, can’t find it: can you give me the exact time that I made that last post? I can’t seem to find it… Gimme that and I’ll copy the logs…

This is the time I get - you can hover over where it says 1d and it should show you the time. I suspect the time shown is in my timezone (gmt+2).

December 10, 2013, 12:25pm

Ah, missed that, thanks…
This is huge, I’ll put it on Pastebin…

I’m already noticing that WindowServer had a freakout: it sent so many messages in the scope of a few seconds that I had to cut them own for PasteBin to accept it.

Edit: Oh, and TotalSpaces reports exceptions and dumps data after that, so that should be useful…

Thanks, that’s very useful.

It looks like the WindowServer is throwing errors that causes TotalSpaces to no be able to do anything - hence the timeout errors. I need to think about this. I wonder if it is specific to the GeForce 9400.

hi. i’ve also been having these errors. Happened a couple of times already:
here’s the log:
macbook 5,1 (aluminum unibody 2008) also with nvidia 9400m

Just so you know, it happens also on my MacBook Pro 13-inch, Mid 2010 Graphics NVIDIA GeForce 320M 256 MB

Might not be TotalSpaces doing it: something like this happened to me with MissionControl recently.
When PasteBin starts taking my pastes again, I’ll have to send a bug-report to apple…

Did you see something along the lines of
WindowServer[117]: CGXNextSurface : IOAccelReadLockSurface(0x14773)
in that log? He’s thinking WindowServer’s causing the crash…

TotalSpaces does tax the graphics system, by using all those mirror windows that show your real windows. Mission Control does that too - but it scales them smaller so that the GPU load is less.

So I’m thinking that for some reason there is triggered some issue in the window server that would not normally be triggered.

I am trying to figure out a way around this. I may be able to do something with the crash watcher that will allow recovery from this situation (by having some way to restart - My original plan of having a separate code path in the Dock plugin that cancels the grid may not work, because from your logs I think Dock is totally blocked by the window server at this point.

As for fixing the bug, I probably need to get a few more clues before I can figure how to avoid this.

Yes, I’ve had the same issues since upgrading (if you can call it that) to Mavericks. I didn’t connect at first that it might be Total Spaces causing the freeze, but what people are describing here is exactly what happened on my year-old MacBook Pro. I have 9 Spaces, if that makes a difference. I use my laptop 12 hours a day and have been freezing (no way out except shut down and restart) 2-3 times a day. I thought I’d time-traveled to the 1990s! Finally I thought to try quitting TotalSpaces and haven’t frozen up since. I LOVE TotalSpaces (Mavericks “bringing back” Spaces is NOT the same!) and really hope you can find a fix for this so I can go back to using it!

so, happened againm but this time i had a chance to look at the console. i’ve pasted all errors in console here:

regarding previous question, no other error in windowserver.

Hi guys; I believe I’m seeing the same thing. I haven’t had time to review the above thread; about to get on a plane, but I will review carefully soon. I just wanted to add some input in case it’s helpful:

TotalSpaces2 has been rock solid for me for a while, but mysteriously, this morning I’ve suffered 3 times in a row lock ups while in Overview mode. I can’t escape overview.

I’m on the latest version of TS2

I’ve repaired disk perms and repaired disk.

I’ve now disabled ts2 hotkeys; thinking there may have been a race w/ 10.9’s hot corners.

I’ll report back if there are more crashes even in this limited state.


P.S.: please let me know if I can provide more info.


I have managed to reproduce a hang on my machine. Possibly not the hang you are seeing, but anyway I think it’s worth trying this version:

One other note - in this version if TotalSpaces notices that the Dock plugin is not responding, it will kill so that it restarts. If you are stuck, pressing the grid hotkey again will make TotalSpaces notice, but it may take ~30s for the timeout to happen. But at least this should avoid you having to restart your machine in this circumstance.