Text Burn-In when using transparent backgrounds (since Yosemite)

Fonts seem to “burn” themselves into the background, very often from other tabs. See screenshot for clarification.
Sometimes the text comes from the same tab. This only seems to happen with TotalTerminal, not with a window with the same profile.

Steps to Reproduce (on my machine)

  • Choose transparent background
  • Open multiple Tabs with stuff in
  • Slide up terminal then down again
  • Change Tab
  • Text from the other tabs is now “burned in” to the transparent background

This goes away when sliding back down, changing the profile and various other things that seem to enforce a re-render.

OS X 10.10
TotalTerminal 1.5, confirmed on 1.5.4

+1, I’m having the same problem. I tried updating to a pre-release and the issue remains.

OS X 10.10
TotalTerminal 1.5 and 1.5.4

I have the same problem, and it is really annoying. Couldn’t find a fix.

Hope someone will be able to help.

+1, I have noticed this issue as well. OS X 10.10.1, TotalTerminal 1.5.4

(transparence, OS X 10.10.1, TT 1.5.4)

this issue is quite bothersome. Thanks in advance for the developer for addressing this bug.

Open your Terminal preferences, go to Profiles > Window > Background (Color & Effects), and set a light blur.

I use 30% to keep anything in the background from disturbing the readability of thin fonts on an already translucent window, so I never noticed the “burn-in” effect when moving to Yosemite.

Still occurring on OS X 10.10.2.

Unfortunately, seems like @darwin and the dev team hasn’t had time to work on TotalTerminal. Looks like it’s the end of an era… might be time to reconsider iTerm2 for me!

That would be really sad, I love ToalTerminal and I just bought TotalSpaces. They have good ideas on usabilty, I’d rather pay a couple of bucks for a working version if thats what it takes.

Yep, TotalTerminal has probably saved me countless hours over the past few years. I know maintaining free software that has to keep up with a changing OS is not easy, so no hard feelings. Thanks for all the work darwin!

Trick with blur 30% just bluring the ghost text behind not resolving that issue. Any news on this? I think they should make donation button for TotalTerminal in order to keep motivation to work on it.

Same problem here.

Great little piece of software that comes in really handy. Would not mind to donate/pay a couple of bucks.

TotalTerminal Version 1.5.4
Mac OS X 10.10.4

+1 — Visor / TotalTerminal is one of my critical development tools on OS X. Was very surprised to see this weird behavior when I got my new MacBook. I’m running Yosemite (10.10.4) and TotalTerminal 1.5.4.

+1 for this one. Not happy to say this problem is getting me to think switching to iTerm2 or something. Is TotalTerminal even being updated anymore? I would easily pay 5$ for a decent version where this is fixed.

I don’t want to set blur to 30% because I actually want to see text on the background.

TotalTerminal is not going to work on El Capitan without System Integrity Protection disabled. That is why I stopped developing it and switched personally to iTerm2. I’m sorry, but I won’t fix this one.