TF 1.9.0 keeps prompting me to install SIP component

bug

#1

Much like somebody else who posted on the blog post re: TF 1.9.0; I don’t want to turn SIP on. Upon installing TF 1.9.0 it asked to install the SIP component, which I did, but then TF would show a dialog everytime telling me it was now ok to enable SIP.

So… I decided to delete that file and now whenever I start it instead nags me to install the SIP component, even though I’ve already clicked “No thanks” and “Don’t remind me again” at least two times.


#2

Thanks for reporting this. I’m going to test it and fix it. There definitely should be a working option to “Don’t show this again”.


#3

I found the bug. In case when you have SIP fully disabled and you perform the first step of installing TotalFinder’s system component (TotalFinderSIP.osax), there is a dialog which reminds you to disable SIP. This dialog was missing the option for suppression.

This will be fixed in v1.9.1. A workaround for now would be in Terminal.app:

 sudo rm -rf /System/Library/ScriptingAdditions/TotalFinderSIP.osax

(Assuming you have still SIP fully disabled) This will delete the system component and return you to situation when TotalFinder will prompt you to install it. That dialog has the suppression option.

Please note that you have to kill TotalFinder.app via Activity Monitor.app and also restart Finder.app via CMD+OPT+ESC, before launching /Applications/TotalFinder.app to prompt you again.

Hope this helps. I’m sorry for the inconvenience.


#4

Thanks for noticing the missing dialog, but my problem right now is that even though I check the suppression box on the latter dialog, it still shows up again when I reboot.


#5

Ah, you are correct. I forgot test the flag before showing the dialog. It will be fixed in 1.9.1. Right now I don’t have a workaround for you to get rid of the dialog. Hopefully I will release 1.9.1 during this weekend.


#6

Should be fixed in v1.9.1:
https://totalfinder.binaryage.com/changelog-beta#1.9.1


#7

It isn’t, though. Now both dialogs have the “Don’t prompt again” option but the flag doesn’t actually appear to be working for either of them. No matter how many times I click “Don’t prompt me again/Remind me later”, it always pops-up again when TotalFinder is relaunched.

In case it’s relevant, I’m still on 10.11.6 BTW.


#8

Just to say that I have the same problem than Lord_Kamina. With SIP totally disabled, the option “Don’t prompt again” in v1.9.1 is not working. In my case I’m in 10.12.4.


#9

I have found this stupid bug. Finally fixed in TotalFinder 1.9.2:

https://totalfinder.binaryage.com/beta-changes#1.9.2

Thanks for bearing with me.