BinaryAge

Total Finder 1.12.3 and OSX 10.15.4 Arrgh!

Total Finder 1.12.3 in OSX 10.15.4 seems quite unstable and crashes or does not launch on restart.
All advice would be welcome!
Thank you,
Long time paid user

I have the same problem on start-up. Once started I can run the app again and it works

Same versions are working fine for me. I do have a macro that launches TF 5 seconds after Finder starts. I don’t know if that’s what’s making mine launch reliably.

@theadler A crash report could help me. I assume TotalFinder Crash Reporter did not prompt you to send me the crash report.

Maybe try to run this diagnostics script for me and send it to support@binaryage.com
https://gist.github.com/darwin/aad9b3f0eca7761c3e72d13e85496134

thanks

Have you partially turned off SIP? I have both debug and FS turned off as my standard configuration and have had no problems with loading TF as part of my login. If I run:
csrutil status
I get the following results:

System Integrity Protection status: unknown (Custom Configuration).

Configuration:
Apple Internal: disabled
Kext Signing: enabled
Filesystem Protections: disabled
Debugging Restrictions: disabled
DTrace Restrictions: enabled
NVRAM Protections: enabled
BaseSystem Verification: enabled

This is an unsupported configuration, likely to break in the future and leave your machine in an unknown state.

Note that it says unsupported configuration. I have had no problems with this configuration throughout the entire macOS beta cycle. I am currently running10.15.5 beta (19f621).

You can try this by doing the following:
Boot into recovery mode
select Terminal from the menu line
run: “csrutil disable” (turns off SIP)
reboot
boot into recovery mode (2nd time)
Select Terminal
run “csrutil enable --without debug --without fs”
reboot.
run “csrutil status” and you should get the results shown above. Now TF should run on boot up. (Obviously, you type the command without the “quotes” . If this isn’t your personal machine, I wouldn’t advise doing this, and the commands in csrutil are preceded by double - as in – )

I have also noticed an issue. I have the tabs enabled with narrow tab bar and sometimes the tab will go black after having been open for a while. I close the entire finder window and start over with my tabs.