Total Finder crashes and loses tabs

TotalFinder (v1.7.3) crashed and when I restarted, I lost all my tabs. Can I recover them by restoring an old preferences file via TimeMachine? Which file(s)? I tried restoring ~/Library/Preferences/com.binaryage.totalfinder.plist from TimeMachine but that did not work. Thanks

This just happened to me too around 11am MST (Oct 7, 2015). All of a sudden I get a message that finder tabs plugin has crashed (or something similar to that) and TotalFinder is completely dead. This happened on my iMac and MBP.

I thought it was just a problem on the iMac, but now I’m wondering what’s going on since it’s on 2 of my Macs.

Also, both machines are performing poorly now.

I’m not aware of any issue with tabs state saving in recent TotalFinder versions. Just one person reported a similar issue over email.

@iTolyan Did you send the crash report gist link to me? I could take a look.

@Ted Yes, tabs state is stored in ~/Library/Preferences/com.binaryage.totalfinder.plist, but it is not safe to overwrite it while TotalFinder is running. And there is also some OS caching mechanism for plist files in play. You should restore this file while TotalFinder is not running at least (use CMD+OPT+ESC to restart into basic Finder and start it after you have backup in place).

There was no crash report link.

And no error message at all when I try to reopen totalfinder.

I’ll restart and try to grab a screenshot.

Ok, I was incorrect. There was a crash report link but only for Apple. I’ll PM you the details from that.

@darwin Just PM’d you the info.

Also… VERY strange. Magically TF on my iMac now seems to be working fine. (still broke on MBP)

Thanks. Unfortunately your crash was unrelated to TotalFinder code. Finder crashed on its own. I’ve been seeing this crash quite a lot recently…

To resolve the issue on your MBP please try to kill via CMD+OPT+ESC. Then delete ~/Library/Preferences/com.binaryage.totalfinder.plist and then launch again. It should start clean with preferences reset to defaults.

Or better move that file somewhere for backup.

Ok, sounds great. Thanks so much for the quick replies and help.

1 Like

That worked perfectly @darwin

Thanks again

1 Like

Just an fyi… The problem (for me) with Finder is recurring. I’ve had to remove the plist 3 times so far. Doh!