Total Finder not working on Monterey 12.6

Hi there.

Thank you guys for TotalFinder that I love so much. I’ll even be willing to pay for it in the future if needed.

Unfortunately I can’t get it to work on Monterey 12.6.

SIP is disabled, the app is correctly installed, all needed security permissions have been given, the app even launches and keep running in the background, but nothing happens in the finder or in the menu bar…

I see no trace of total finder anywhere except that I can see the app running without issue in the background in activity monitor.

I tried to uninstall totalfinder completely and reinstall it Multiple times, but still nothing happens…

Am I missing something ? How can I solve this ? Any help would be greatly appreciated ! Thanks !

Anyone ?

Hi there
wait for next ver I think it’s coming tonight or maximum tomorrow

Thanks for your answer Welaxx !

I hope it will indeed work with the next ver.
But I’m curious, did Anybody managed to make TotalFinder work on the latest Monterey release? (12.6.2)
Am I the only one having this issue or does other people are currently having this issue too ?
I tried everything to make it work but still with no success.

  1. SIP is disabled
  2. I ran the following command in Terminal
    sudo defaults write /Library/Preferences/com.apple.security.libraryvalidation.plist DisableLibraryValidation -bool true
  3. Totalfinder is properly authorized in Security and Privay/Privacy/Automation.

But I still get the “Trouble Launching TotalFinder / TotalFinder Injection Troubles” notification and nothing shows up in the menubar or in the finder even though TotalFinder is running without issue in the background (activity monitor). I tried everything on the " Troubles launching TotalFinder" page.

The only thing I didn’t tried was
sudo rm "/Library/Application Support/com.apple.TCC/TCC.db"
But I’m worried it would start to break stuff on my system…

Do you think it’s worth trying ?
What are the risk concerning my current setup and all my other apps ?

Also I wonder why we are going through all this, cause other apps easily modify the finder like the “New File Menu” app just by enabling Finder Extensions in System Preferences / Extensions / Finder ?
Is it because it’s free ?

Thanks !

@Barral39

Hi — can you provide more information regarding your system?

  1. Is this an Apple Silicon (arm64e/AArch64) or Intel/AMD (x86_64) system?
  2. Are you using OpenCore Legacy Patcher? (Specifically, the root patches. The OpenCore UEFI bootloader itself should have no impact.)

I can confirm that TotalFinder works fine for me on macOS 12.6.2 21G320 Monterey (latest version as of this writing), on both Apple Silicon and Intel/AMD.


Running that (and then rebooting) will completely reset the permissions of every app on your system — for instance, if you granted Discord access to your microphone, after running this command, it will ask you for those permissions again.

This will apply to every single application that has requested special permissions in the “Privacy & Security” preference pane.

It should not have any other adverse effect on your system.


The cost has nothing to do with it (※ TotalFinder was actually previously a paid software product) — the actual reason is actually because TotalFinder is a full macOS tweak that directly modifies Finder in very major ways, much like an iOS jailbreak tweak.

“Finder Extensions” work entirely within the intended security model and “sandbox” that Apple wants them to work in.

TotalFinder, a macOS tweak, completely disregards what Apple wants and hooks into Finder directly to modify its functionality, which allows us to add far more features than a Finder Extension ever could.

Thanks a million time “akemin_dayo” for your detailed answer ! It’s really appreciated ! :star_struck:
Thanks also for the upcoming 1.14.4 version !

  1. I have both PCs (that I build myself) and Macs but my current main Mac Machine is an Intel one :

Mac Pro 6.1 (Late 2013)
2.7 GHz 12-core Intel Ivy Bridge-EP Xeon (E5-2697 v2) with 30 MB L3 cache
2 x AMD FirePro D700 6 Go
64 go Ram
1 To Apple SSD (1500 mb/sec R/W)
Monterey 12.6.2

Yeah that’s what I though about sudo rm "/Library/Application Support/com.apple.TCC/TCC.db"
but as I have tons of apps and a complex setup I’m afraid it’s gonna take me forever to grant all those permissions again. I’ll do it if needed but I’ll gladly avoid it if possible.

My God if only there was a way of totally bypassing the “Security and Privacy” thing on mac, Windows is way more permissive…This and the not writable Macintosh SSD/System and Macintosh SSD/Library is just pain…

I understand for the Finder Extension thing, yeah I was using XtraFinder a long time ago but it doesn’t work anymore on my mac pro either…Xtrafinder always crashes after 10 sec, and Totalfinder runs fine never crashes but never shows up, it just keep sending me the “Trouble Launching TotalFinder” notification.

I should mention that I bought Pathfinder and I use it, it’s quite amazing but I would still prefer keeping the original Finder with a plugin like Totalfinder than a complete alternative solution like PathFinder.
Anyway the Totalfinder problem occured even before I installed Pathfinder so…

So what would you suggest me to do ? What can I try to make TotalFinder work on Monterey ?

Is removing the “com.apple.TCC/TCC.db” the only way ?

Or is there anything else I should try or investigate ?

Thanks again for your Help and knowledge !

Update : Finally got TotalFinder to show up !

Like “ChrisOSX” I had to work my way backwards installing versions back to 1.12.3. Anything beyond this version throws the Injection error. It’s still weird that this version show up when launching and not the more recent ones…

But the BIG ISSUE is TotalFinder preferences are almost Empty…I have access to almost no functions,
Here are the screenshots :



Also I have allowed TF to modify the Finder but It seems impossible for me to allow access system events for TF in the Privacy/Automation tab…Can you show screenshots of your SysPref / Security and Privacy / Privacy concerning TF in Monterey 12.6.2 ?

@Barral39 Hmn, that is very odd.

Try downloading TotalFinder 1.15.0 (the latest version as of this writing), running the uninstaller, rebooting, and then trying to install and use TotalFinder 1.15.0.

If the issues persist, I will ask you to run a diagnostics script (diagnose-totalfinder.sh found in the latest versions of the TotalFinder.app bundle).

Thanks a lot for your answer :star_struck: !!

First I should mentioned that when I try to uninstall I always get this error :

“osascript: can’t open default scripting component.”

01

1 Like

@Barral39 … Huh. That’s uh, concerning.

AppleScript (osascript) might be slightly broken on your system. This means the TotalFinder uninstaller may not have completed correctly.

Do you happen to have any third-party audio units (AUs) installed in /Library/Audio/Plug-Ins/Components?

Specifically, certain outdated versions of FabFilter Pro-C 2?

(I know this sounds absolutely insane, but I have seen cases in the past where this specific AU plugin caused AppleScript to break.)

In fact I do. I just red online that some audio plugins can cause these issues…insane…But I have tons of plugins for audio production so…I’m not gonna go through each of them…I do have Fabfilter Pro C 2.

Should I remove the component…? what exactly should I do with it ?
Remove only the component ? The VST also ? or complete uninstall of the plugin ?
Is it only Pro-C or all Fabfilter Plugins version 2 ?

@Barral39 Try moving that specific AU plugin somewhere else (to your Desktop, for instance) and trying again to see if the issue still occurs.

You shouldn’t have to remove the VST versions — I think the issue only affects the AU.

Also, I think it’s just that specific plugin (the compressor) and not all Fabfilter AUs, but I could be wrong.

If the issue persists, try moving the other Fabfilter AUs, too.

This may actually explain why you run into intermittent TotalFinder injection issues — TotalFinder relies on AppleScript functionality to inject into Finder.

Yeah would have been too easy…I tried moving All Fabfilter AU but issue still persist…

1 Like

Ok it’s definitively an AU causing this…I tried moving all AUS and it worked

01

The little issue is that I have currently 93 Audio unit components. So how do I f… know which one are causing this issue ? Yeah I think I know the answer to that = couple more hours to fiddle with this…

1 Like

@Barral39 While you have your AUs disabled — try installing and using the new TotalFinder 1.15.0. Does it inject correctly?

Yes it works of cuuuurse it’s these god damned plugins…so I guess now I’ll have to go to each of them (93 Audio units) to find out which one was causing the issue…Hate my life…
Still Huge thanks to you !!! :heart_eyes:

1 Like

@Barral39 Glad you found the cause.

Once you figure out which AUs are causing it, check to see if there are any updates to those AUs.

Also, VSTs should be wholly unaffected, so you can continue using those without any issue.

Yes God thanks it’s only AU !

It was preventing TF to access “system events”.