Total Spaces doesn't work... mostly


In this video I mostly try to change current space; and, though it is not visible, not only it doesn’t work, it tries to move in the wrong direction! I tried shortcuts and swipes. I don’t even know how to explain it in more detail.

Very strange.

  1. Does this happen all the time, or did it only recently start happening?
  2. If you reboot, does the issue go away?
  3. Please check that the same swipe gestures are disabled in System Preferences > Trackpad.

Let me know what you find.


Well, I’ve just installed TotalSpaces on my MacBook since I’ve completely reinstalled the system about a month ago (I’m running the latest OS X 10.11), so, I guess, both: it technically just started, but was happening ever since installation.
I’ve tried — rebooting doesn’t help, nor does reinstalling TotalSpaces.
And yes, the gestures are disabled; though I doubt the cause would be there — keyboard shortcuts do not work as well (well, they try to, but…).

My theory is that your Spaces don’t have unique IDs. Have you tried closing all your Spaces, then re-opening them (which creates a new ID)?

Also, let’s see if there’s more information about this issue in the Console:

Nope, nothing happening. I closed and re-launched every Space but nothing changed. Nothing in the Console as well:

By the way, could it be that TotalSpaces conflicts with Amethyst (tiling window manager)? It was closed during these tests, but could it have changed something? Though I don’t think it interfered with the Dock, because I didn’t do anything to SIP to install it, but could it be something else?

Well bummer. Nothing obvious in the logs.

I’m still pretty new, so please forgive me while I’m still getting up to speed.

Would you mind trying the latest pre-release build to see if it helps?

Yep, that helped! Thank you for your help =)