BinaryAge

Total Spaces Fail in Catalina

Just updated to Catalina 10.15.1 and noticed I need to update TotalSpaces (which I’ve used for years). So downloaded 2.8.5, turned off the System Integrity Protection. My normal 2x2 “TotalSpaces” setup worked, I setup my hotspots, and hot keys. NONE worked! The only way I could access a space was via the toolbar icon. It was impossible to move a program from space to space like I’ve done in the past. Spaces would suddenly switch for no reason. Quite often a space would lock up and it was like the clicking on the left mouse button had no effect!!! Had to use the power reset button (2017 iMac 27") to regain control. One time playing a video full screen and the video finished I could not go back to a normal screen, had to power cycle. After a day of frustration I removed TotalSpaces and things are now normal in that I haven’t had any lock ups! Never have I had problems like this before! Bob

Sorry I don’t know why this is happening, but I’ll investigate asap.

Hi again, I’ve had a look at 10.15.1 just to check that there is nothing I missed. I don’t find any problem on my test setup, so I’m not sure what’s causing the issue.

I wonder if there are some permissions issue? In particular, for TotalSpaces2 hotkeys to work, input monitoring permission must be granted, see graphic.

Did u use that iMac alone or use with any attached external display?

I have exactly same problem at iMac Pro 5K without any external display see at TotalSpaces support on MacOS 10.15 Catalina
TS2_failed

Problem is in the “input monitoring permission” i think.

No problem on My MacBook or iMac 27" with exactly same version of Catalina.