TotalFinder 1.13.6 not working on m1 laptop

Not quite sure if this is a Big Sur issue or an m1 chip issue, but I can’t seem to get TotalFinder to launch properly on my m1 laptop. I’ve disabled SIP and made the defaults writes change to Library Validation but I still get an apple events error when i launch.

I’ve tried uninstalling and reinstalling the release version and then the latest beta but am having no luck. Happy to send along any logs if that helps narrow down the issue.

I’m waiting for my M1 machine, so I cannot really confirm if TotalFinder can run there.
But I have two people who cannot make TotalFinder inject even when they have all expected settings properly set. So there must be some other permission setting interfering with sending apple events between TotalFinder and Finder.

Do you see any errors in when you open /Applications/ (maybe filter the list with “Finder” keyword)

Let’s talk over at Better not share logs publicly.

btw. this looks relevant:

Error loading /Library/ScriptingAdditions/TotalFinder.osax/Contents/MacOS/TotalFinder:  dlopen(/Library/ScriptingAdditions/TotalFinder.osax/Contents/MacOS/TotalFinder, 0x0106): missing compatible arch in /Library/ScriptingAdditions/TotalFinder.osax/Contents/MacOS/TotalFinder

I will see if I could add arm architecture in next version (I thought the option was already enabled in the compiler)

There are some initial rumblings that may affect the way TotalFinder works on M1 devices.

Currently, you need to disable SIP on your Mac to run TotalFinder.

It is being reported that on M1 devices, if you attempt to disable SIP it locks you out of being able to use iOS apps on your device.

So, if TotalFinder is still dependent on SIP being disabled, that could be a major stumbling block moving forward.

Can confirm, I cannot get totalfinder working on a m1 mac with sip disabled.

1 Like

I’m the same. MacMini M1. Can not get TotalFinder to work. I followed all the steps in the support section, and can get TotalFinder showing in the system preferences > security & privacy > privacy pane under automation (but it won’t install in the system preferences > extensions pane). But no luck at all to get it to inject, or operate.

Yep, I confirm. I cannot tell more because I haven’t received my M1 machine yet. Still waiting for the delivery. Sorry for that.

Yes certainly not working on M1 after following all of the steps discussed in the forum. Hopefully a new fix comes soon.

There are probably several applications that do not work on M1. XtraFinder (that’s recently been updated to run on Big Sur) is one of them.

PathFinder and DCommander both work.