TotalFinder 1.6.17 installation Failed

TotalFinder 1.6.17 installation has been failed. Has anyone got any idea?

I hesitated to revive an unresponded to ‘legacy’ thread, as it may not be very relevant to most forum visitors, but the thread’s title fully matches my issue.

I’m unable to get TotalFinder installed again, having removed it before upgrading to 10.11.

Gonna supply a little more background on my issue than the OP did about his.

I have a mid-2010 MBP that until recently had never been upgraded past OS X Mountain Lion (10.8.5). I very much adopted TotalFinder into my workflow, and had to have been using it for years and years. A few weeks ago however I decided to give OS X 10.11 El Capitan a go, having recently upgraded my internal drive from a spinning disc to a SSD.

Prior to the upgrade to OSX 10.11, I wasn’t actually aware of the technical limitations (without a tweak) on TotalFinder in El Capitan. However, I had decided prior to the upgrade that I was going to rely on Finder’s in-built multiple tab feature (which OS X 10.8 did not yet have) rather than TotalFinder anyway. So before installing El Capitan, I uninstalled TotalFinder using the uninstall feature it (TotalFinder) includes.

I was shell-shocked to learn that TotalSpaces (which I rely on hugely) is a no-no on El Capitan without a tweak, which I wasn’t prepared to implement. So I reverted to Mountain Lion using a full Time Machine backup.

Then a short time ago this evening I tried to reinstall TotalFinder, but the installation failed. To be clear, when I first tried the reinstall of TotalFinder, I used “TotalFinder-1.7.10.dmg” that I downloaded just now from the website. I did note that this dmg’s ReadMe file states that the minimal supported OS X for this version is “Mountain Lion (10.9)”. [To the guys at BinaryAge: This is a (syntactic) error in your ReadMe, I’m afraid: It has to be either ‘Mountain Lion (10.8)’ or Mavericks (10.9)’ that you mean]. Despite the ReadMe’s inconsistency in the numbering of the OS, I went ahead and attempted installation of the 1.7.10 file on Mountain Lion 10.8.5, but it failed.

I quit the installer and then checked my discs for older TotalFinder DMGs and found TotalFinder-1.6.17.dmg. Its ReadMe file correctly cited the minimum supported OS X version as Mountain Lion (10.8). However, that installer too returned an identical install fail error as the 1.7.10 dmg had:

So now I’m in a pickle, unable to get TotalFinder back up and running. TotalFinder had always worked really well for me and I never had any technical hitches to speak of.

I imagine that, at this point, I may need to undo what may have been done by the (two) install attempt(s) this evening. So I would appreciate any advice please regarding:

  1. How to remove all traces (through Terminal command if required) of TotalFinder so I can start afresh. Have I damaged my system by attempting to install the 1.7.10 dmg on it, given that it is only meant for OS X 10.9 or above (and not 10.8.5?)? [Aside to devs: Please correct your ReadMe!!]. Can I safely correct any ‘damage’ done by the failed install?
  2. If I get that far, which DMG should I then use??

Thank you in advance.

Look forward to any responses.


Please open -> var/log -> install.log

There should be some more verbose error description what exactly failed with the installation.

This file could be huge, you might want to backup/delete the existing one and then try to install TotalFinder again, so you have there just relevant content.

And btw. the compatibility table is here - 1.6.17 is the best version for 10.8 systems:

Thank you for the reply and for the emails Antonin. I have emailed you the install.log document. The entries relevant to TotalFinder took place early on the morning of January 24th.

Looking to forward to any light you may be able to shed.