TotalFinder 1.8.1: Finder becomes unresponsive when opening a .dmg-file

As said in the subject…
Finder gets unresponsive while opening a .dmg-file.
I have to “Force Quit” -> “Relaunch Finder” and then restart TotalFinder.

I’m running TF 1.8.1 on Sierra 10.12.1

I also have this problem on two Apple computers, both running El Capitan 10.11.6 and TF 1.8.1. One is an Apple iMac and the other a MacBook Air.

In addition (on both computers), when I relaunch Finder, the Sidebar is devoid of most items I had switched on and I have to re-select them.

Just tried in on my MBP and it worked as intended.
With the next “Force Quit”-Situation on my iMac, I used Activity Monitor to kill TF and TFCrashWatcher for good.
Then I uninstalled TF1.8 with AppCleaner, to make sure every file outside the app is also deleted.
Afterwards I rebooted the machine and reinstalled TF1.8 and now it seems to work again… :slight_smile:

Having the same issue, this resolved this problem?

EDIT: I just tried this and it still locks up.


Sorry for the late reply…
Since 1.8.1 the issue is gone.
Even the almost 2 GB Combo-Update dmg for 10.12.3 worked like a charm.

“Even the almost 2 GB Combo-Update dmg for 10.12.3 worked like a charm.”

How did you get a combo update? The only kind of update I can get with Sierra is an automatic one.

Take a look at the following link:

Thanks. I like having a spare copy.

I’m still having the issue, I’ve even tried a beta of 10.12.4 to see if that bug fix carried over and it has not.

Could you test this plist tweak? Thanks

1 Like

This worked. Is a permanent fix on the way?

I have reimplemented the way how I detect DMG files. The issue should be fixed in the next version (1.8.3)


@darwin - Thanks for the update. Has there been a date (or at least month) set yet when 1.8.3 will be released?

This should be fixed in new TotalFinder beta:

I would appreciate if you could report back if you still encountered it with 1.9.0. Thanks!

1 Like