BinaryAge

TotalFinder corrupted after icon change. How do you change the icon then?


#1

So I took the tip from here: http://pastebin.com/m8fCaxPb to change the TotalFinder Finder icon. After that, TotalFinder won’t launch anymore and console says it’s because “shell is corrupted”

I will reinstall TotalFinder, since it will fix the launching, but I still want to know how I’ll be able to change the finder icon. I have done it before, but for the life of me can’t remember how I did it. I just did a reinstall of Mavericks and it reset a lot of customised icons back to normal. I managed to change them all, even the Finder icon, but as soon as I launch TotalFinder I get the old Finder icon.

Any help is much appreciated!


#2

Well, it has been resolved. I changed all Finder icons, and .png’s I could find. Restarted the Mac and it now works. I wish there was an easier way to it though :wink:


#3

Well, this check is quite recent. I had to add it because some cracked TotalFinder versions caused continuous Finder crashes under Mavericks.


#4

So is there any way to change the icon? I ran into the same error with TotalTerminal when trying to update the icon to the new Terminal icon from Yosemite.


#5

I’m open to change signing requirements and allow resources to be modified by users. Unfortunately it would require some research of “codesign requirements” to allow it selectively:

I’m using codesign the simplest way - to sign whole archive and not allowing any modifications.

If you have time, a patch would be welcome.