TotalFinder crash constantly

Hi. I’m experiencing a crash everytime I try to open the dropbox folder from the menubar icon (, or the applications folder from dock ( and from the finder sidebar ( Also, sometimes it crashes if I doubleclick Macintosh HD from desktop ( It seems the crashes happens only when there are no finder windows open. If there already is a finder windows open, it doesn’t crashes in any of this occasions. My opinion is it can be related by the folder on top sorting that causes a memory leak because the window starts to show few elements of the folder and then goes in crash.

Best regards

Yes, it is definitely related to folders on top and it looks like all crashes happened in Column View.

When column view receives notification that data source changed, I try to re-sort the content of the folder and then let Finder do its display job. Something goes wrong with my sorting I guess, because when it Finder handled my sorted list of files it crashes 3 or 4 calls deeper in the stack.

I wonder if this could be caused by some asynchronous nature of Dropbox folder. That data source changes but some additional changes are in-flight and when my code does sorting some other thread jumps in and touches data I’m working with.

I have just briefly tested it here on my 10.11.4 system with dropbox 3.14.2 and it seems to work without crashes for my dropbox folder.

Some ideas to try:

  1. try to switch dropbox into offline more
  2. try to quit dropbox, disable Dropbox Finder integration (so dropbox folder won’t be special)
  3. try to temporarily move Dropbox folder content elsewhere just to test if it depends on content

Thank you Darwin for your very exhaustive reply.

I’ll try it but I don’t understand why sometimes it also happens with Macintosh HD. I’ll reply to this post when I have more informations.

Best regards

Any new observations? I have another user experiencing the same crashes. Not in Dropbox folder tough.

Hi Darwin sorry for the late reply. I updated TF and the crashes still happening but just before I restarted dropbox…

This is the crash report with paused dropbox

This is with dropbox paused and wi-fi off

If I turn off dropbox all works well, and if I restart dropbox, all keeps to works well… Restarted the macbook and all keeps working well… If I experience future bugs I’ll post the report here

Thanks Enrico.

I don’t User Dropbox. In my machine TF crashes almost every time (80 to 90 per cent) when I enter the Applications folder from the side bar, or the Download folder from within Safari (“show in finder”). OS X 10.11.3.


I did an experimental build for you to try:

Please test it and report back if the crashing is still happening. Thank you.

Okay thank you.
I installed it in both my machines I’ll let you know later tonight or tomorrow if I don’t experience any crashes. I had the same problems of mike33 but happened very rarely.

Using the experimental build of TF… it still crashes, but when I fully uninstalled TF using AppZapper and reinstalled it the crashes doesn’t seems to happens anymore.

Before completely reinstalling TF and finding that what I think is the solution, I have found how to make crashing TF:

install TF - open TF - close all finder windows - open dropbox folder from app.

…and it was happening everytime I reinstalled the experimental build or others.

A little diary of my 2 hours of tries… (to read optionally :P)

I tried to remove all the files (except the shared folders) from my dropbox (5 folders). I waited to finish the sync but it still crashes. FYI one folder is protected from writing, others are shared and I’m the owner.

I also tried to completely uninstall TF using AppZapper, now the app seems to don’t crash but it takes 2-3 seconds since when I press on the dropbox folder for opening a new window with the dropbox files.

The app now works well, dropbox opens immediately without delays and re-using the same TF settings as before the app doesn’t crashes. I’m an old user of TF, maybe the problem was in a older release.

I also uninstalled the experimental build and installed the 1.7.11 and all still working fine.

I don’t know if it’s good because now I think we will never know what was the problem…

The funny thing is that all of it is happened in the machine with an activated copy of TF. I in my office iMac with same public beta build of OSX, and with the unregistered version, it never crashed, surely because the iMac on my office is newer and I started using TF on it when the bug was already solved, but before finding this solution at 2am, i was thinking that the problem could be caused by registering the product, strange but I thought I had tried all :slight_smile:

I hope I did something useful for the developing of your amazing application instead of beings a loss of time for you. I’ll continue to try your beta versions and reporting eventual bugs.

Cheers and thank you for simplifying our working lifes with Total Finder! God bless you

1 Like

Yes, I’ve had this as well, and it does seem to be a problem in column mode when the directory is refreshed or changed.

10.7.11 seems less fragile, so far.

@eBara Thanks for your detailed description. So the bug is still there even in v1.7.12. I don’t think this is related to registration, it is more likely that this bug is a race condition / timing issue. It will be really hard to catch until I’m able to reproduce it on my machine :frowning:

@darwin Same here when entering the folder “applications”. I did a clean install (uninstalling v1.7.11 via AppCleaner incl. the .plist file). Maybe you are right that it is a timing issue. I observed, that the Finder (without TF injected) sometimes needs nearly a second to show all files in “applications”. To be more precise: Entering “applications” with Finder (without TF) shows only 2 files for a second, then the rest of the files show up. Entering “applications” with TF shows the same 2 files for a second, then TF crashes.


Maybe your machine is too clean :slight_smile: go on appstore and install all free apps!! :smiley:

(opening Applications folder crashes to me too, occasionally, even after a clean installation :frowning:)

Good news! I was able to reproduce the crash on my machine and found a workaround. But I’m not sure how stable the solution will be. Needs testing.

Please test version 1.7.12:

You are the best :slight_smile: I’m trying it, all seems to work fine for now. I’ll be in a job vacation in the next 2 days I will try it better on Friday.

Best regards

1 Like

Just installed the new 1.7.12, SIP enabled. Entering the folder applications. TF shows only 2 files for about 1 second. Then… TF shows up all the rest (@eBara: 128 objects, so no need to install all free apps from appstore :sunglasses:)! It seems, that you did it, darwin! Hat off and congratulation to you. Crossing all fingers, that your solution will be stable.


1 Like

Not a single crash over several days with 1.7.12! I am very relieved. Thanks darwin.


1 Like

Thanks for getting back in touch. Today I published 1.7.12 on main update channel for everyone.

No crashes for me too! Thanks darwin!

1 Like