BinaryAge

TotalFinder does not work on macOS Monterey 12.0.1

I have disabled SIP. (Command + R, csrutil disable)
The icon in Finder is that of TotalFinder. However, when I click on the icon, there is no response and the window does not open.

Please let me know how to fix this.
Thank you for your cooperation.

I have this same problem!

Yep, me too! :face_with_head_bandage:

Same. Killing TF allows me to get to native Apple Finder, but nothing allows me to get to TF. Tried the icon on the Dock, tried selecting a folder in Spotlight search, tried showing all results in finder with Spotlight. No luck.

Unfortunately, TotalFinder is no longer supported under macOS 12 Monterey:

https://blog.binaryage.com/totalfinder-totalspaces-future

Thank you for the information.
I understand that support is ending.
TotalFinder was very easy to use and I liked its functionality and design.
I’m sure you had a lot of difficulties in developing it, as Apple’s “barriers” such as the introduction of SIP became more and more severe every year.
I would like to thank you for providing us with such a wonderful software for many years.
I hope to be able to use your software again when you release a new product.

2 Likes

I actually do NOT have the same problem; and I was the first to report many bugs with TF through out its more recent history.

Finder does indeed work with TF installed (at least coming in as an upgrade from a previous version of macOS, like Big Sur). Tabs work without issue. Which in my opinion, is the very BIGGEST reason to use TF, as Apple’s tab implementation - under the Toolbar - absolutely sucks.

But Tabs works. I’ve seen this on more than one Mac in my house, so I know it works via an OS upgrade path.

What doesn’t work are the Cut, Copy & Paste buttons. They display, but don’t do anything except depress when you click them. The Context menu does not disappear when you click one; and the file you have cut or copied won’t paste anywhere.

The keyboard shortcuts for cut/ copy and paste don’t work, and neither do the commands in the Edit menu, though they appear in the Edit menu. Whatever code object is used to inject that functionality into Finder is being blocked.

However, again, Tabs works without an issue AND you can copy and move files back and forth with those tabs. So its not a complete loss…

@darwin I really appreciate you and this product, more than you’ll ever know. It’s a shame you can’t continue to make it work under Monterey. However, I will be pleased and grateful with and for what I have.

TF works for me under 12.0.1. So does C/C/P buttons.
I installed with SIP off and have kept it off during the beta builds and did a full install today over the previous incremental betas and all is well.
TS I miss not working but at least TF works.

This is not fair. We talked many times about it and you said TF will not be supported with M1.
For me TF works except the cut/copy/paste buttons what are the important functions.
So couldn’t be so hard to fulfil your promise to keep TF alive up to the M1 Mac.

That is at least what you can do is to provide und with the full functionality in Monterey.
M1 is understandably, by Moterey not.

Also it can’t be a big change, when it still works for User Michael_Rebar Mac (see comment above)

Thanks in advance for keeping your word

GS
Nurb2kea
(We talked about TF and the TF code & sharing it with other dev. for M1 mac’s)

TotalFinder 1.13.10 is not officially suppored under macOS 12, but you can make it work with limited functionality:

Reset Finder and TotalFinder into factory defaults and do not enable “Show sidebar icons in color”:

Thank you for providing a solution.
The following two points did not work, but the others are working fine.

  1. The “Show cut button in contextual menu” function does not work.
  2. I need to follow the macOS standard for moving files.
    (Not command + X & command + V, but command + C & option + command + V)

Thank you very much for providing the solution, even though it is unofficial.

It really involves a lot. Please make it work and add an upgrade fee…?

1 Like

I’m with you. I just bought a new imac intel for some use reason. So I have this one at least two years.
M1 wouldn’t have done the trick.

So for the sake of Monterey and following OS until M1 only macOS, I would love to see TotalFinder work on NON M1 Mac’s till then.
Anyways, support said ‘Will work until M1 Silicon Mac’s (ARM)’

I looked up all alternatives for TF, but they all have more downsides than basic finder, buggy, missing functionality, no support anymore, etc…

PS: We have to keep in mind that the Intel Mac’s are still sold, the next years. SO there is no reason to make TF stopp working until we have a ARM only macos!!!

Also willing to pay an upgrade fee if that helps.

Ok good points. I sat down and made a new version for you. TotalFinder 1.14.0 should be compatible. Please give it a spin and report any issues, thanks.

https://totalfinder.binaryage.com/beta-changes#latest

3 Likes

Hey darwin, a very big thank you for version 1.14.0. It works under macOS 12.0.1 on the Intel macbook pro without any problems. Thank you, you saved my day.

3 Likes

I want to echo the kudos for 1.14.0 . I loaded it over 1.13 and now have TF back on my Mac-Mini under the Monterey beta (21C5021h). So far everything works as expected. Many, many thanks.

1 Like

Thank you very much for developing TotalFinder 1.14.0. It’s a pleasure to be able to use Command + X, Command + V to manipulate files and directories as well as move text. Thank you very much.

1 Like

Thank you very much. Works fine for me. Haven’t had an issue since 1.14.0.
Hope the next update from macos 12 isn’t wrecking it again.

Can’t belive why apple isn’t including TF options into Finder. Everyone uses Cut/Copy/Paste and needs to copy between two folders. But no, you have to live with crappy Tabs.

Anyways, thank you! :wink:

Thanks a bunch. It works !
:clap: :clap:

Nurb_2Kea, thank you for pointing that out. Not everyone has an M1 Mac. And Darwin, thank you for fixing TF.

1 Like