TotalFinder does not work

Hello all!

Recently I uninstalled TotalFinder, using CleanMyMac to remove all traces of it, before upgrading to a new version with a clean install.

Now, whenever I install any version of TotalFinder (I’ve tried three, one being a beta version)… install is successful, the TotalFinder menu appears in Finder, but Finder is not modified in any other way - the only reason you can tell it’s installed is because the additional TotalFinder menu appears in the Finder menu!

I have tried force quitting Finder in Activity Monitor, restarting the Mac, and nothing helps… any ideas? Apparently CleanMyMac didn’t remove everything as TotalFinder still remembers my registration details, even once I’ve uninstalled and re-installed.

Any help would be very much appreciated.

Thank you very much! :smile:


I have this same exact problem. Tried to install the new Mavericks-compatible version on a brand new MacBook Pro. Please help.

Please open and then try to launch /Applications/, it should log some errors there.

Hi Darwin, thanks for the reply!

When I launch TotalFinder I get the following log in Console:

27/03/2014 08:24:45.698 TotalFinder[29057]: agent v1.5.22 started (TotalFinder)
27/03/2014 08:24:45.700 TotalFinder[29057]: requesting injection into[12075]
27/03/2014 08:24:46.268 TotalFinder[29057]: already injected - nothing to do
27/03/2014 08:26:59.470 TotalFinder[29057]: requesting injection into[12075]
27/03/2014 08:26:59.777 TotalFinder[29057]: already injected - nothing to do

It’s also worth mentioning that although Finder still looks exactly like default Finder, I now have the ability to use Cmd + X to cut and paste between folders! Also, I was promoted to install the latest version of TotalFinder today, and still no change to the issue.

It looks to me that TotalFinder works but for some reason it has disabled some features. Do you see TotalFinder tab in Finder preferences? (CMD+,)

Can you please force quit via CMD+OPT+ESC. Then launch /Applications/ and see again. There could be some messages that TotalFinder has disabled some plugins. Maybe Tabs plugin is disabled?

That fixed it!

The reason TotalFinder appeared not to work is because “Tabs” were disabled in the TotalFinder preferences.

Maybe you should try this too @acurattack… open Finder, click on “Finder” in the top left of the screen, then “TotalFinder” then “TotalFinder Preferences” then click on the “TotalFinder” tab and then “Tabs” on the left… you will see the following options (as screenshot below), check to see that “Disable tabs completely” has been un-ticked.

Thanks a lot for your help Darwin, you’ve just helped speed up my workflow :wink:

Have a good day :smiley:

Kind regards,


Wow. That did work for me, too! Why in the world were tabs disabled? Thanks for the tip!!

Ah, now I recall some other people had similar issues and emailed me on our support email.

This is a mystery. Probably a bug on my side. TotalFinder probably corrupts its own settings under some circumstances. This needs to be investigated!

I’m glad you have resolved it. Hope I will find the reason why it happens.