TotalFinder Integration Problem (High Sierra)

I’ve tried uninstalling, remove all plists I can find, reinstalling, all the same result.

Can you help me for a solution ?

Could you record a screencast (or give me a few screenshots) what are you exactly doing with the Dock and TotalFinder? Maybe you are clicking something else than I do.

i will,
(it is not really dock related, also on mounted shares or hdd from the desktop.)

if you double click on the hdd, and after that double click on a mounted share or folder on the desktop, 1 get one total finder tab with underneath 2 finder tabs, (not the 2 total finder tabs I get on my iMac)

first open 1 (doen’t Mather which folder)
Then 2: open ssd from dektop (result in a new tab in Mac finder)
with 3: click on the open folder shortcut
by 4: opens a 3th finder window.

with non of them opens a second total finder window as on my iMac does

have you any idea ?

I just tried to reproduce it here on my machine and it works as expected. All folders get opened in TotalFinder tabs not in Finder’s native tabs.

Could you please run this script and send me your report back?

I will look at your totalfinder plist, maybe there is some hidden tweak or something causing this.

I’m also trying to solve it from here, I think I found the solution.

In system settings under “dock” there is a another option, " open documents in tabs" with a pull down menu for " always" , “only in full screen” and “never”

it was on always (sounds logic) now I placed it on “only in full screen” and it works like is should.

As I tough it needed to be a setting as it works on my other iMac and also no one else had this problem.

thank you in advance for your feedback

Oh my gosh, thank you for asking this question @morphf and thank you for answering @darwin! I asked basically the same question in Open all new folders as TotalFinder tabs and I finally have my answer!

For what it’s worth, setting “Prefer tabs when opening documents” to “Manually” works too. Anyway, @darwin and @stephen, I think this information is worth adding to your support documents.

Wow. This must be something new. I didn’t know this existed.

Great detective work @morphf. Thanks!

@PatrickF Good point, I have just updated TotalFinder’s web page about tabs:

@darwin no problem, but after your latest update I have a nother strange thing.

when I open a window (total finder) and open another window (total finder) 1 got 2 windows with both one tab of the open window, not 2 tabs in one window.

any suggestion?

Can you be more specific? How exactly do you open the windows? (keyboard shortcuts, mouse, external app)

I don’t hear from people that something about opening windows changed recently…

just double click on 2 folders on desktop, or in downloads

tried to change settings in dock, finder and total finder, but unfortunately no success, did a new install same behavior, so I did a restore from backup, also no luck.

someone any suggestions left ?

I tried to reproduce it briefly. But was unable to. All seems to work as expected here.

Have you tried to trash TotalFinder and Finder plists?


I tried that as well, but no luck :cry:

@darwin can I make a log or a live action to view for you ?
i have no idea where and how to search next

i did also checked on my work, (ols imac 2011 updated to high sierra) it works like it should be.

But on my macbook 2017 with a fresh instal, every folder opens in a new window (if i double ckik a folder on a desktop for example)
(if i click on a folder in totalfinder, it just opens in that window)

so can somone help to solve this mistery ?

This is puzzling. Can you observe any difference between old machine and new machine when clicking on problematic folders in basic Finder only?

unfortunly no, I don’t see any difference except any folder I click opens in a new window on the new machine, on the old it opens in a new tab.

(clicking folders from the side bar or in the total finder viewer just opens that folder in the same window on both machines)

and with the new update, the problem is solved, works like before ! :+1:t2:

1 Like