Totalfinder Lauches very slowly in macOS Sierra

bug

#1

After upgrading to the final version of macOS Sierra from El Capitain, I noticed the 'spinning wheel would come on for a while during login. It turns out that it is the Totalfinder launching (even the latest version 1.8.0). Has anyone been experiencing this?


#2

Yep, the same here.


#3

Same here the only way is not to turn off the laptop too often, it works well after that slow login


#4

I agree, but this behavior was not present in El Capitan…


#5

Update… although this still does not resolve the issue of the spinning wheel…

During my testing I went into recovery mode and moved the file from /Library/ScriptingAdditions/TotalFinder.osax to the folder /System/Library/ScriptingAdditions. Then I changed the right of that file in that new folder: chown -R root:wheel TotalFinder.osax

Now total finder can run with SIP fully enabled.


#6

I too have the slow load of TotalFinder.

Has anyone also noticed that “Show Hidden Files” doesn’t show hidden files in all folders, the Downloads folder for example?

This isn’t a TotalFinder issue as the command works but it might be something that fellow users have noticed?


#7

Same for me with Sierra 10.12.1
Very slow startup of Totalfinder!


#8

I can confirm the issue is there, please fix it


#9

for me too. So annoying. :frowning:
Is there a fix in sight?


#10

Hi guys,

TotalFinder comes with another app running in the background called TotalFinderCrashWatcher. This is the app that is causing the spinning wheel when you launch TotalFinder. My solution was to simply kill TotalFinderCrashWatcher app and locate it with the TotalFinder.app (context menu > Show Package Contents) and delete it. So far perfect!

enjoy!


#11

Hello,
Yep, it’s working now :wink: Thanks for your tip!


#12

Now working for me as well! Thanks for the tip!
Now I hope that the Totalfinder team, fixes the issue soon!


#13

Awesome! Thx for the tip!


#14

:thumbsup: You are my hero! :thumbsup:

Been tolerating the insufferable startup beach ball since Sierra. Removed TotalFinderCrashWatcher & then I needed to restart my computer several times just to witness & revel in how fast it starts up now. :slight_smile:

Now if someone could only figure out how to replace ALL the sidebar icons with my own custom color icons, I’d be in TotalFinder bliss! Time to hunt the forum & see if there’s a solution for that!

Thanks!


#15

Hi guys,

My apologies for this neglected issue. I’m going back to TotalFinder and investigate it soon. If the problem is really just the CrashWatcher launch, you can disable it via Terminal.app using this tweak:

defaults write com.binaryage.totalfinder TotalFinderDoNotLaunchCrashWatcher -bool yes

and to enable it again

defaults delete com.binaryage.totalfinder TotalFinderDoNotLaunchCrashWatcher

Please report back if this solved the issue for you.


Beach ball @ startup OSX 10.12 Sierra
#16

For changing Icons in the Finder Sidebar:
Go here:
/Applications/TotalFinder.app/Contents/Resources/TotalFinder.bundle/Contents/Resources/icons2.plist
Copy that file to your Desktop and edit it (with TextEdit or different editor) the way you want -> Put the path to your icon inside the “key”.
Save the file and paste it inside the original location. Type in your admin password to replace the file.
Restart Finder and enjoy your icons! :slight_smile:


#17

Hello. That solved the delay problem. Completely.

I wonder… what was the Crash Watcher for? I suppose that if put it there is for something…

Thank you so much.


#18

I have the same question what was the Crash Watcher for?


#19

TotalFinderCrashWatcher is a process which reacts to Finder.app crashes. It looks what caused the crash by inspecting the crash call stack. And if it was something likely caused by TotalFinder, it offers a dialog for submitting the crash report to us (instead to Apple).

In another words, TotalFinderCrashWatcher is not essential for TotalFinder operation.

btw. back in 2010 I wrote an article about it:
https://blog.binaryage.com/crash-reporting-in-binaryage/


#20

Like many others, I left TF because I wasn’t comfortable disabling SIP (Yes, yes, I know. Our systems ran just fine before SIP, but still…). Anyway, I just came across this post and the update by @rjrggr and decided to give TF another chance. I can confirm that @rjrggr’s tip works as advertised with one minor change.

After moving TotalFinder.osax to /System/Library/ScriptingAdditions and re-enabling SIP, TF continued to work fine except for changing certain options. In particular, options that require a Finder restart such as disabling tabs. Presumably because TF needs to write to /Library/ScriptingAdditions/TotalFinder.osax and it isn’t there. I suspect that TF updates would also fail for the same reason.

The problem appears to be solved by a simple symlink from /System/Library/ScriptingAdditions/TotalFinder.osax back to /Library/ScriptingAdditions (I did this In a regular login shell; no need to boot to the recovery partition). All options now seem to work, I have column autoresizing goodness and fully enabled SIP. Yay.

p.s. @darwin’s tip works for me as well.