BinaryAge

TotalFinder license info lost or settings got unexpectedly reset

TotalFinder stores its settings in

/Users/<user>/Library/Preferences/com.binaryage.totalfinder.plist 

Sometimes this file can get deleted by some aggressive system cleaning utilities (MacKeeper, CleanMyMac). Or it gets corrupted/reverted by some other means.

Since v1.6.23 TotalFinder can detect this situation and at least issue a notification to inform the affected user. Newly TotalFinder also stores a backup of TotalFinder licensing info in Finder’s own plist. So in situation of losing totalfinder.plist, the license is hopefully still kept somewhere else to be recovered automatically.

Please report your experience with this issue here.

1 Like

everytime I reboot/logout(in)/relaunch finder I have to reenter my credentials. everytime. only thing that comes to mind right away is that my license info in any/all possible instances isn’t be saved correctly? …possibly a permissions bug?

I’ve never had any software behave like this in my MBP 8,2 's lifetime… so I’m inclined to suspect its uniqueness to total finder specifically. Please let me know how I can help with moving forward to resolve this issue.

all the best,
QQ

<< post.script. >>
oh and I’ve definitely gone through all the motions of full uninstall/removal of every trace leftover that root find cmd can find…and then fresh install with same issue :confused:

I would like to talk to you in private conversation. I would like to run some debug version of TotalFinder on your machine to investigate what went wrong.

Please write to support@binaryage.com, thank you very much.

HI, i’ve got the same problem, every time i reboot my mac it lost the license key. It happens even when i reboot totalfinder. any solutions?
thanks

@Marco_Masiero: Please install TotalFinder 1.7.1 (beta):
http://totalfinder.binaryage.com/beta-changes#1.7.1

The problem should go away.

Hi there, Almost every time I log in, Totalfinder tells me it has lost my settings due to a corrupted plist. I’m using Yosemite on a MBP from mid 2012. Any suggestions for trouble shooting? Thanks.

@firefly: I wonder what can be causing that. Do you use CleanMyMac, MacKeeper or similar? Are you on latest TotalFinder 1.7.1 beta, right?

@Darwin, I don’t use CleanMyMac etc but I’m not on the beta version. Let me download that and get back to you. Thanks!

I installed the beta, but still have the same problem. I did discover my work IT folks have installed McAfee, so I have tried to exclude Totalfinder from its processes. But I’m still having the same issue.

I have the same situation. Every time I logout or reboot the Mac, TotalFinder license information vanishes.

@denva are you running the latest beta? It should not be happening there anymore:
http://totalfinder.binaryage.com/beta-changes#latest

Hi, thank you. I have installed the latest beta (v1.7.2), and the issue is gone.

1 Like

FWIW, this just happened to me with 1.7.12 when I rebooted into 10.10.5 after having booted into Bootcamp before. I surely did not use any apps that would attempt to uninstall anything. At least, TF managed to restore the prefs from its backup, it seems.

It has worked for me. CleanMyDisk or somehow my license was initially signed as lost but here i am. Thanks a lot!!!

Finally I missed so much using TotalFinder that disabled the SIP