BinaryAge

TotalFinder MacOS BigSur 11.2.2

Hey,

can someone help. Since 11.2.1 Totalfinder doesn’t work. I tried a lot, but nothing works.
In System → Security → Privacy _> Automation is only the TotalFinder Uninstaller listet und not the normal TotalFinder Application.

I tried all of this article but with no effect… Help would be great =)

https://totalfinder.binaryage.com/injection-troubles

Greetz

I’m presently running beta 11.3 with TotalFinder with no problem. I ran it under all of the release versions as well. Do you have SIP disabled? When TotalFinder installed did you go to Security & Privacy and allow the helper app to load? I’m not saying it will work, but do a search for “Turning off Gatekeeper” and see if that will allow TF to load.

I have turned Gatekeepe off but with no effect.

The problem os that i don’t get the question for allow TotalFinder to load in Security & Privacy

And i have no idea what i can do for getting this message.

TotalFinder is not Listet in Security & Privacy → Automation =/
What can i do to manuell allow the helper app ?

Good News i finde a Solution… i

Here my Solution… i
1.uninstall TotalFinder
2. running all Steps from here TotalFinder Injection Troubles
3. reboot
after reboot i had problem to add any program in privacy so and to fix this the solution was to clear sic and nvram
4. Reboot and Press Command + Option + P + R after 2 Booting Sounds - System starts and SIP is enable
5. reboot with Command + R and use in terminal csrutil disable for deactivating SIP
6. reboot and install TotalFinder…

Working for me…

Okay, you just saved me from having to type out all those steps for you :slight_smile: It should work fine. You can do a partial re-enable of SIP if you’d like by going to Recovery mode (Command +R), opening a terminal window and typing, all in one line the following:

csrutil enable --without debug --without fs

You’ll get a message saying it’s not a supported configuration. I’ve been running that same configuration since Apple started SIP so I guess it’s not that much of a problem. Glad you got it fixed.

Thanks for helping, i will do that later…

have a nice week

Glad it’s fixed for you. Hope your week is great one as well.

Hey Ken,

quick replay, i tried your command, but after the reboot TotalFinder told me that i must deactivate SIP for using… Is it maybe only usable in a beta of macOS ? Or what can be the reason ?

Did you copy and paste the command or type it out? If you type it, please note that there are two dashes before “without debug” and two dashes before “without fs”. so it looks like --without debug --without fs.

Now I’m going to go to Recovery mode and make sure :grinning:

Okay, let’s go all the way back to the beginning :grin:
Step 1: Command + R to go to recovery
Step 2. In Recovery, open a terminal window and type: csrutil disable
Step 3: Reboot
Step 4: Command +R to go into Recovery mode
Step 5: Open a terminal
Step 6: Type csrutil status - Should report SIP is disabled
Step 7: Type csrutil enable --without debug --without fs (note the double dashes before the word “without”
Step 8: Close the terminal, go to the upper left, click on the Apple and select reboot. (of if you’re lazy like I am, I just type reboot in the terminal window). Now TF should work as expected and you have a bit of SIP protection. If you type “csrutil status” now, it will say SIP is disabled, but it’s really not and if there are updates to TF, you can now install them without going through all the “recovery mode, turn SIP off, reboot, recovery mode, type above command, reboot” nonsense.

Isn’t this fun? :grinning_face_with_smiling_eyes:

Thanks for your detailed explanation, but it isn working… i have made a screenshot…
And i have use double dashes… And i have no Idea why it is not working for me… =((

Okay, I’m now officially perplexed. I’ve been running that SIP configuration since Mojave. I think at this point, just go with SIP disabled. That’s very strange because that’s the configuration active here.

Didn’t follow whole discussion. But here is my understanding of disabling SIP partially with TotalFinder:

The behavior of csrutil changed between OS versions!

I am now running (as of this morning) 11.3.beta4 (20E5210c) with the same configuration I’ve been running since the beta of Catalina. This config (in Recovery mode): csrutil enable --without fs --without debug. If I do csrutil status from the regular screen (not Recovery), I get the following:

Configuration:
Apple Internal: disabled
Kext Signing: enabled
Filesystem Protections: disabled
Debugging Restrictions: disabled
DTrace Restrictions: enabled
NVRAM Protections: enabled
BaseSystem Verification: enabled

Your results from csrutil status:

Apple Internal: disabled
Kext Signing: enabled
Filesystem Protections: disabled
Debugging Restrictions: disabled
DTrace Restrictions: enabled
NVRAM Protections: enabled
BaseSystem Verification: enabled

I get exactly the same status as you with a whole lot less commands.

TotalFinder installs/works/update with no problem. Maybe I’m just lucky or Bill Gates has blessed my configuration or something, but (so far) I’ve had no problem using this configuration.

Phill; Looking over your status results, you show Debugging still enabled. Did you type on the command line in Recovery mode: csrutil enable --without fs --without debug
Debug is still enabled and if you see my status in my last post, you will see that debug is disabled.

I will try it tomorrow :slight_smile: and report after trying…

Sorry boys for the late answer, i tried it with darwin´s solution and it works for me…

Maybe Ken the deferents is that you use MacOS Beta and in this version is your command working…

But we have now a Solution for alle people with a similar problem =)

Have a nice time, thanks for helping …

I’m glad you got it working, Phillip. I was beginning to think I was imagining things. :smile: Not sure why the short command didn’t work, it’s been working for me since Catalina but, Darwin’s works for you and that’s all that counts, I’m always happy to help out in any way I can (even when it doesn’t work :smile:

-ken