TotalFinder on macOS Sierra beta

Good news! I updated my Retina MacBook Pro to 10.12 Sierra and TotalFinder seems to be working well. I have been using Visor and Dual Mode frequently, so far with no real issues. Finder itself now has a Folders On Top feature but there seem to be no ill effects when used with TotalFinder. The additional context menus seem to work fine too.

Of course I do have system app protection disabled with SIP, but I didn’t have to do anything special after updating my El Capital system with TotalFinder already installed.

Overall I’m quite pleased that updating caused no problems whatsoever for me. I hope everyone else has a similar experience! :slight_smile:


Whoa, I didn’t see that, but you’re right. This will be nice as “Folders on Top” is fairly unstable in El Capitan (with TotalFinder).

Color labels need some work, but we’re also pretty surprised it’s working so well =)

1 Like

I’m getting frequent crashes myself (crash report has been sent in, Steve).

The internal error dialogue is as follows:

Exception Name: NSInternalInconsistencyException
Description: NSBrowser should not have two first responders
User Info: (null)

0 CoreFoundation 0x00007fffbd4865db __exceptionPreprocess + 171
1 libobjc.A.dylib 0x00007fffd0c41a2d objc_exception_throw + 48
2 CoreFoundation 0x00007fffbd48b2c2 +[NSException raise:format:arguments:] + 98
3 Foundation 0x00007fffbee9551d -[NSAssertionHandler handleFailureInMethod:object:file:lineNumber:description:] + 195
4 AppKit 0x00007fffbb4bea8a -[NSBrowser setLastColumn:] + 666
5 Finder 0x0000000100656f87 Finder + 868231
6 Finder 0x000000010065e1c7 Finder + 897479
7 Finder 0x0000000100600548 Finder + 513352
8 Finder 0x00000001006001f2 Finder + 512498
9 Finder 0x0000000100a32883 Finder + 4913283
10 Finder 0x000000010063f95d Finder + 772445
11 Finder 0x0000000100635d49 Finder + 732489
12 libdispatch.dylib 0x00007fffd14e9d54 _dispatch_call_block_and_release + 12
13 libdispatch.dylib 0x00007fffd14e0ed6 _dispatch_client_callout + 8
14 libdispatch.dylib 0x00007fffd14ee94b _dispatch_main_queue_callback_4CF + 925
15 CoreFoundation 0x00007fffbd43c2b9 CFRUNLOOP_IS_SERVICING_THE_MAIN_DISPATCH_QUEUE + 9
16 CoreFoundation 0x00007fffbd3fd3cd __CFRunLoopRun + 2205
17 CoreFoundation 0x00007fffbd3fc8cd CFRunLoopRunSpecific + 285
18 HIToolbox 0x00007fffbc9d127c RunCurrentEventLoopInMode + 240
19 HIToolbox 0x00007fffbc9d0fb9 ReceiveNextEventCommon + 184
20 HIToolbox 0x00007fffbc9d0ee6 _BlockUntilNextEventMatchingListInModeWithFilter + 71
21 AppKit 0x00007fffbb140101 _DPSNextEvent + 1093
22 AppKit 0x00007fffbb845a0c -[NSApplication(NSEvent) _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 670
23 Tabs 0x000000010b013cc1 Tabs + 81089
24 AppKit 0x00007fffbb134a3e -[NSApplication run] + 929
25 AppKit 0x00007fffbb100367 NSApplicationMain + 1237
26 Finder 0x00000001005891b2 Finder + 25010
27 libdyld.dylib 0x00007fffd151b285 start + 1
28 ??? 0x0000000000000001 0x0 + 1

Just wanted to chime in to say that I’m getting the same frequent crashes with the same exception/description as @Guid0man.

The crash seems to occur when I:

(1) Click on the sidebar in TF when I am more than one folder deep in Column View; in other words, if I am at the highest folder level (e.g., the first column), then I click on the sidebar, no crash occurs. However, if the focus is currently on the second column or later, then I click on the sidebar, TF goes crashy-crash.

(2) Right-click to “show package contents” on some types of packages. For example, I can “show contents” on a .app file, but not a .osax or .bundle file. Specifically, I use a custom re-colored Visor button (sorry, not a fan of the default purple-y color :slight_smile: ) and TF crashes consistently when I attempt to “show contents” on TotalFinder.osax.

Currently running Sierra build 16A238m. I will re-post if I find any more specific crash triggers.

Just updated to Sierra build 16A254g and it appears the crashes have stopped for me; the crash triggers I described above are no longer causing problems. Will update if problems return.

Is there any different method to disable SIP on Sierra that is required? I’ve tried running through the instructions provided for El Capitan (and that have worked for me on that release) to no avail with the Sierra betas. I still get the Totalfinder crash immediately upon startup.

Let’s see if there’s more information about this issue in the Console:

Here are the results. I also emailed the crash log using the built in error reporting dialog.

Aug 24 07:55:58 Jays-iMac TotalFinderCrashWatcher[1679]: ‘/Users/plater/Library/Logs/DiagnosticReports/Finder_2016-08-24-075557_Jays-iMac.crash’ crash report was related to the target app -> open Crash Reporting Dialog
Aug 24 07:56:20 Jays-iMac TextExpander[1658]: Secure event input has been enabled by: TotalFinderCrashWatcher (com.binaryage.totalfinder.crashwatcher)
Aug 24 07:57:07 Jays-iMac spindump[1110]: Saved spin report for TotalFinderCrashWatcher version 1.6.27 (1.6.27) to /Library/Logs/DiagnosticReports/TotalFinderCrashWatcher_2016-08-24-075707_Jays-iMac.spin
Aug 24 08:15:29 Jays-iMac TotalFinder[959]: agent v1.6.27 started (TotalFinder)
Aug 24 08:15:31 Jays-iMac TotalFinder[959]: requesting injection into[843]
Aug 24 08:15:31 Jays-iMac Finder[843]: TotalFinderInjector v1.6.27 received init event
Aug 24 08:15:31 Jays-iMac Finder[843]: TotalFinderInjector: You have Finder version 10.12. But TotalFinder was properly tested only with Finder versions in range 10.8.0 - 10.10.5.
Aug 24 08:15:31 Jays-iMac Finder[843]: TotalFinderInjector: Installing TotalFinder from /Library/ScriptingAdditions/TotalFinder.osax/Contents/Resources/TotalFinder.bundle
Aug 24 08:15:31 Jays-iMac Finder[843]: Warning: Finder has unknown version 10.12. TotalFinder has not been tested with this Finder version.
Aug 24 08:15:31 Jays-iMac Finder[843]: TotalFinder was unable to resolve 1 Finder classes. Please update TotalFinder.
Aug 24 08:15:31 Jays-iMac Finder[843]: Launching TotalFinderCrashWatcher from '/Library/ScriptingAdditions/TotalFinder.osax/Contents/Resources/TotalFinder.bundle/Contents/Resources/’
Aug 24 08:15:31 Jays-iMac TotalFinderCrashWatcher[1093]: Watching ‘/Users/plater/Library/Logs/DiagnosticReports’ for new crash reports with prefix 'Finder’
Aug 24 08:16:02 Jays-iMac TotalFinder[959]: TotalFinder has been succesfully injected into[843

Very quiet in this front… TF forgotten? Or something else… :confused:

I hope not… !!! keen to support this software though I understand the challenges Apple throws at the developers locking them out with SIP :smiling_imp:

<< I updated my Retina MacBook Pro to 10.12 Sierra and TotalFinder seems to be working well. . . . I didn’t have to do anything special after updating my El Capitan system with TotalFinder already installed. >>

I too had no problem with TotalFinder (v 1.8.0) after updating to Sierra on my rMBP. On my retina iMac, however, TotalFinder will not launch after updating to Sierra. I keep getting the error message: “Troubles launching TotalFinder. Apple Events cannot be delivered.” I repeatedly tried the recommended maneuver in the Terminal (sudo killall -KILL appleeventsd), but that hasn’t remedied the problem. I’m open to other suggestions!

Sorry for the radio silence. Please confirm your Sierra build version so I can take a look. Apple seems to be seeding slightly different builds to different beta testers.

I’m using the official, final release. I’m about to reinstall TotalFinder to see if that has any effect.

I just reinstalled TotalFinder (v. 1.8.0) and all is working again! Thanks for your quick attention!

1 Like

Interesting, but 1.8.1 is no good?

Some days ago, I encountered a problem with 1.8.1 that I can’t recall now. It might have been some non-responsiveness. I also noticed in the update dialogue box that 1.8.1 had been “removed” for some other reason. That prompted me to go back to 1.8.0, which has given me no problems to speak of.

I always got this internal error when I was double tapping or right clicking.

Exception Name: NSInvalidArgumentException
Description: +[NSArray FINodesFromFENodeVector:]: unrecognized selector sent to class 0x7fffcca8ea80
User Info: (null)

0   CoreFoundation                      0x00007fffb22cd52b __exceptionPreprocess + 171
1   libobjc.A.dylib                     0x00007fffc69a5cad objc_exception_throw + 48
2   CoreFoundation                      0x00007fffb234ec74 +[NSObject(NSObject) doesNotRecognizeSelector:] + 132
3   CoreFoundation                      0x00007fffb223fbf5 ___forwarding___ + 1061
4   CoreFoundation                      0x00007fffb223f748 _CF_forwarding_prep_0 + 120
5   NutstorePlugin.cocoa                0x00000001154988de +[FinderMenu updateNodes:] + 42
6   NutstorePlugin.cocoa                0x0000000115498e0a -[NSObject(MenuPatch0) myConfigureFromMenuNeedsUpdate:clickedView:container:event:selectedNodes:] + 53
7   Finder                              0x000000010fa6e3e7 Finder + 3490791
8   AppKit                              0x00007fffb006c48a -[NSMenu _populateFromDelegateWithEventRef:] + 334
9   AppKit                              0x00007fffb0068da1 -[NSMenu _populateWithEventRef:] + 84
10  AppKit                              0x00007fffb006b5e1 -[NSCarbonMenuImpl _carbonPopulateEvent:handlerCallRef:] + 468
11  AppKit                              0x00007fffb006b317 NSSLMMenuEventHandler + 1093
12  HIToolbox                           0x00007fffb17bd0d5 _ZL23DispatchEventToHandlersP14EventTargetRecP14OpaqueEventRefP14HandlerCallRec + 1708
13  HIToolbox                           0x00007fffb17bc346 _ZL30SendEventToEventTargetInternalP14OpaqueEventRefP20OpaqueEventTargetRefP14HandlerCallRec + 428
14  HIToolbox                           0x00007fffb17bc18f SendEventToEventTargetWithOptions + 43
15  HIToolbox                           0x00007fffb1803d39 _Z16SendMenuPopulateP8MenuDataP20OpaqueEventTargetRefjdjP14OpaqueEventRefhPh + 320
16  HIToolbox                           0x00007fffb18300a3 _ZL15SendMenuOpeningP14MenuSelectDataP8MenuDatadjjP14__CFDictionaryhPh + 305
17  HIToolbox                           0x00007fffb1828119 _ZL19PopUpMenuSelectCoreP8MenuData5PointdS1_tjPK4RecttjS4_S4_PK14__CFDictionaryPK10__CFStringPP13OpaqueMenuRefPt + 1237
18  HIToolbox                           0x00007fffb1827483 _ZL26_HandlePopUpMenuSelection8P13OpaqueMenuRefP14OpaqueEventRefj5PointtjPK4RecttS6_S6_PK14__CFDictionaryPK10__CFStringPS0_Pt + 612
19  HIToolbox                           0x00007fffb182705b _HandlePopUpMenuSelectionWithDictionary + 287
20  AppKit                              0x00007fffb01ab86f _NSSLMPopUpCarbonMenu3 + 6218
21  AppKit                              0x00007fffb02bdd4c -[NSCarbonMenuImpl _popUpContextMenu:withEvent:forView:withFont:] + 240
22  AppKit                              0x00007fffb02bdb98 -[NSMenu _popUpContextMenu:withEvent:forView:withFont:] + 201
23  AppKit                              0x00007fffb06e82af -[NSView _showMenuForEvent:] + 85
24  AppKit                              0x00007fffb02b7ad1 -[NSView rightMouseDown:] + 100
25  AppKit                              0x00007fffb03ba940 -[NSControl _rightMouseUpOrDown:] + 515
26  AppKit                              0x00007fffb074b130 -[NSWindow(NSEventRouting) _reallySendEvent:isDelayedEvent:] + 6458
27  AppKit                              0x00007fffb074942a -[NSWindow(NSEventRouting) sendEvent:] + 541
28  AppKit                              0x00007fffb05ea3f2 -[NSApplication(NSEvent) sendEvent:] + 3190
29  Finder                              0x000000010f7395fd Finder + 128509
30  Visor                               0x0000000114d1921b Visor + 33307
31  AppKit                              0x00007fffafed0009 -[NSApplication run] + 1002
32  AppKit                              0x00007fffafe9aa8a NSApplicationMain + 1237
33  Finder                              0x000000010f71ffde Finder + 24542
34  libdyld.dylib                       0x00007fffc7283255 start + 1
35  ???                                 0x0000000000000001 0x0 + 1

Hi Jason,

On the call-stack you posted there is something called NutstorePlugin.cocoa. That is causing the issue, not TotalFinder.

Got it, Thanks