TotalFinder on Ventura

Working fine on Ventura Version 13.1 Beta (22C5059b) but due to the way Apple has configured Finder in Ventura, Cut and Paste will not work. As of right now, there is no work around.

When you say working fine, does that include colored labels?

No, no colored labels (but that was never a priority for me). I use TF for the tabs more than anything else. That has always been my main use. The one feature that is absent that I do wish was fixed is Cut and Paste which I believe is being sorted, albeit not fixed as of yet.

Thanks for the update. Colored labels is the only TF feature that is a must have for me. The only other feature that I really care about is auto column size, but I have a workaround macro set up in Keyboard Maestro that, while a bit touchy, seems to be working okay for now.

Hi, This works for me on my MacBook 12" 2017 running Ventura.
With Colored Labels disabled though, but I can live without them…
Many thanks

Now that there are reports of TotalFinder working on Ventura, I tried to install it to see for myself.

I keep getting a notice that Apple Silicon support in TotalFinder must be manually enabled.

However, when clicking on the MORE INFORMATION button, nothing happens.

I do have SIP disabled. I have reduced security enabled per the site’s instructions. Nothing is showing up in Finder preferences for TotalFinder so I am assuming I am missing a step to enable it.

1 Like

It’s hit and miss depending on your machine. Some have more features than others if any.

Here’s the latest progress report for 1.14.4

If you had TF installed before and had colored labels enabled, then TF will crash silently on launch when it reads the prefs file. The solution is to delete the prefs file or to use a terminal command to disable colored labels. This is discussed in another thread.

Thanks, Rick.

This was a fresh install.

When I launch TotalFinder I get a Notice regarding Apple Silicon support. All the instructions were properly followed including disabling SIP and reducing the security level under Startup Utilities.

One, I can’t get rid of the splash screen notice, and two, usually in Finder there is a section for TotalFinder where I can set up the Visor function, which is the only thing I use TF for.

I’m on an Intel machine(s), so no personal experience with AS machines. Sorry.

One way to check if TF is running is to check for the Preferences in Finder. Another way is to fire up Activity Monitor and search for “totalfinder”. That will tell you for sure if it’s actually running but not showing in Finder Prefs.

1 Like


Thanks for reporting that you’re experiencing an issue with the “More information” button.

I’m uh… honestly somewhat confused as to how this even broke (as all TotalFinder is doing is using bog standard macOS APIs to open a web page, of all things…), but I’ll definitely need to re-test all of the info dialogs and see if I can reproduce your issue locally and then fix it.

Anyway, all that button does is open the Apple Silicon-specific documentation — however, I believe what you specifically are missing is this part of said documentation, as that’s what actually triggers the “Apple Silicon support in TotalFinder must be manually enabled.” message.

tl;dr: Run this in Terminal, it should fix your issues.

touch ~/.totalfinder-dontcheckarchitecture
killall TotalFinder; open /Applications/

Also, if you haven’t done so already, there’s an additional boot-arg that must be added on macOS 13 (for now, and also for the upcoming beta release), which you can add by running this in Terminal:

sudo nvram boot-args="-arm64e_preview_abi"

※ NOTE: If you already have other boot-args added for other macOS tweaks (you can check this by simply running nvram boot-args), be sure to include them in the above invocation too!

Let me know if this helps.

That being said, I personally can’t really recommend trying to use TotalFinder on macOS 13 right now, since merely having it enabled at all (regardless of what options you have on) actually causes some Finder right-click context menu options to disappear, as documented here.

The “missing context menu actions” bug has since been fixed in my development build (as noted in this progress report), but I still need to fix two more issues (that are giving me a harder time than expected) before a proper beta can be released.

The Visor feature does work fine, though!

As always, thank you for your continued patience regarding macOS 13 support on TotalFinder.


Thank you so much for your assistance with this. Greatly appreciate the effort you put into providing an easy-to-follow set of instructions to get TF working on OS 13.

A few things…

Apparently, despite checking via terminal if SIP was disabled (Terminal confirmed it was), I did another disable function by shutting down my Mac, rebooting in recovery, and running the CSRUTIL DISABLE command.

I also ran all the terminal commands you graciously provided.

That seemed to fix the issue of the warning coming up when I launched TotalFinder, and for a minute, I thought I actually was able to get this working.

However, an error message came up that Apple Events could not be delivered and there are no TotalFinder options under FINDER.

And, certainly, I can be patient. If it takes months to get this fixed or it doesn’t get fixed at all, that’s fine. I love this software and I appreciate there is still an effort in getting it to work with each OS upgrade.



Did you reboot after setting your boot-args? I forgot to mention that a reboot is required in my original post, apologies for that.

You can also verify that the boot-args have been set correctly by running nvram boot-args in Terminal, and the resulting output should resemble this:

boot-args	-arm64e_preview_abi

me the same.
nvram boot-args is resulting the right output (boot-args -arm64e_preview_abi).
in the activity monitor i can see totalfinder running, but that’s all.

BUT after reboot it WORKS! yes! :star_struck:

1 Like


That did it! That was the missing step. I had to reboot my Mac.

Now that I have, TOTALFINDER is working under Ventura. WOW. So happy!

Thank you, Akemin-dayo for the help. I know it’s an effort to keep guiding many of us, but please know that it is most appreciative and has resulted in getting this great piece of software working again.

1 Like

Discovered the bug that right-click no longer works in Finder.

I take it this is an issue currently being worked on.

Is there a workaround for this?

Hi Ronald,
Good to know you could make TotalFinder (TF) work in Ventura. Please share the steps you followed to make it work. If possible share relevant screenshots.
I am using a MacBook Air M2.

Here is the screenshot of the settings on my Mac.

Also TF is running in the background but does not work. When I open a new Finder window, earlier it would open the TF window.
Not sure what am I missing here. Appreciate your suggestions for fixing it.


Just wait until akemin_dayo is coming up with a solution.
Makes no sense when getting it to work half baked yourself and risking to do chages to the system, so that the solution from akemin_dayo won’t work when it’s released.

Just use xtraFinder in the meantime. It’s free (no need to register) and works well as a temp solution.

By the way, have a merry xmas you all, especially akemin_dayo . :slightly_smiling_face: :santa:

TotalFinder 1.15.0 has been released for macOS 13, 12, 11, and 10.15! (Apple Silicon and Intel/AMD)

All known compatibility issues with macOS 13 Ventura have been resolved — for more information, please refer to the changelog.

See also: The main discussion thread


Thank you sooooo much for the TotalFinder update! It’s like having an old friend come to visit you. I have missed you, and welcome you for as long as you can stay! w_oglesby

1 Like