TotalFinder on Ventura

I know it’s still early in the game but thought I would ask…

I am on the public beta of Ventura. TotalFinder does not work. That’s understandable.

However, I want to be sure…

Is it that TotalFinder is not yet ready for Ventura -or- when installing the new operating system (on top of Monterey) it enables the SIP and must be disabled again?

Thank You


I would try it out with SIP.
But you can check first if you have to do it !!
Goto Terminal and type: csrutil status
This will give you the status of SIP. (enabled/disabled)
So you know if you have to do it or not.

(every time google, if terminal commands are not harmful…)

1 Like


Thank you! Great shortcut recommendation.

SIP is disabled. So, TotalFinder would normally run under that setting, but in this case, it looks like it’s not read for Ventura yet.

Thank you again!

Guess I’m going to have to tell TotalFinder that. I’m running it under Ventura 13.0 Beta 6 and with some minor exceptions (no Cut and Paste but Copy and Paste works), it’s been giving me all the features I’ve come to expect from TF.
Go to the long discussion on TF on Monterey, make those changes and it should work. I’ve been running it since the first beta of Monterey with no problems.

I would love to know what modifications you made to get TF to run under Ventura.

It doesn’t even show up under Finder preferences.

My SIP is disabled (ran the Terminal command to make certain)

I reinstalled the latest version

Maybe there is just a small step that I overlooked?

On a M1 Mac, shut down the machine. Hold down the power switch until you get into Recovery mode. Select Security at the top left. Once you enter your password, select the bottom Security option (I believe it’s “relaxed security” or something similar). Select only the top option (not the remote option) and save. Go back to the main Recovery screen and reboot. Once the machine has rebooted into operational (normal), reinstall TF. That may be the step you’ve overlooked.

I’ve got the same issue with Ventura Version 13.0 Beta (22A5331f). My settings are correct (csrutil disabled and the system security downgraded) yet Total Finder doesn’t want to run. Hoping someone comes up with a cunning plan…

Yeah, nothing is working for me either under those relaxed security conditions.

Surprised we have heard nothing official from the software developer as of yet.

The developer noted in their blog that they dropped support for TotalFinder after Catalina, so Big Sur + is no longer supported, and it sounds like TotalFinder will probably not get any updates going forward. However, someone named akemin_dayo is taking it on themselves to tweak TotalFinger to keep it running. You can check that out here: [Update Discussion] TotalFinder 1.14.2 for Apple Silicon and Intel - #54 by 674423114. There’s a not from akemin_dayo about Ventura, just search the page for “macOS 13”. I need to revisit my beta drive, but I think I had it working on a fresh install. I want to confirm before I update my M1 Mac mini of the RC of Ventura.

I’m trying to see if there are other differences that may keep your Mac from running TF. When you installed, did you by any chance turn on Colored Labels in the Finder/Settings/TotalFinder/File Browser?

I have updated yesterday and am on macos Ventura now. Total Finder is not working anymore. Does not launch. After a restart of my mac I get the message concerning this “Apple Events”. Reseting privacy settings does not work.

Any idea??

See the last posts here. It will take some time…

Running the following from a terminal and rebooting has v1.14.3 working on Ventura:

sudo nvram boot-args=“-arm64e_preview_abi”
defaults write com.binaryage.totalfinder TotalFinderLabelsEnabled 0

Apparently the coloured labels cause TotalFinder to crash and not be recoverable without a full removal and reinstall, the second command disables the coloured labels to prevent this from happening accidentally or otherwise.

It seems to be running smoothly and stable as of now on Venutra 13.0.1. There are a couple of missing items such as the custom context menu with the cut/copy/paste amd copy path features. Using cut/paste from the Edit menu seems to simply copy the file also, but for now I think this is as good as it’s going to get.

I will let you know if there’s any changes or updates.

Thanks! It worked! I missed the TotalFinder a lot…

I don’t think the first one is necessary on Intel. I was able to get TF running by just deleting it’s prefs file and then refraining from enabling colored labels after it starts.

Unfortunately, colored labels is the only really must have feature for me. So I’m waiting to put Ventura on my primary machine for now.

Hi all,
I am currently running TotalFinder 1.14.3 on my Ventura 13.0 Mac OS
It has started after having run the below lines

sudo nvram boot-args=“-arm64e_preview_abi”
defaults write com.binaryage.totalfinder TotalFinderLabelsEnabled 0

but it seems to be missing the Copy/Cut and Paste buttons (even if they are enabled in the settings)

and the window that I see is the below one (a lot of the usual content is missing)

Is it something I did wrong?
Thanks for your help!

Bad luck for me. Tried it also (am on M1) but it doesn´t work. If I try to start TF after these two commands and a reboot it does nothing at all.

1 Like

It doesn’t work for me.

Mac Studio M1 MAX
macOS 13.0.1 Ventura

Even after disabling SPI and running the code in the various information, TF was not able to run.

I only need the color label functionality.
Tag alone is very inconvenient.

the same for me, everything right click doesn’t work if we are in thumbnails, in list mode right click works but not copy/paste