TotalFinder prevents shutdown in Yosemite

When running TotalFinder 1.6.12 on Yosemite it crashes the Finder at shut down.

The finder cannot be restarted, and the computer must be forced to shut down.

Disabling TotalFinder from starting up and rebooting resolves this issue. Upon restart of TotalFinder and attempting to shut down again, the issue repeats.

Shut down proceeds as normal when TotalFinder is disabled.

Could you please provide the Finder crash report? It can be located in -> User Diagnostics Reports.

Please send it to Thanks a lot.

Have similar problem, what means Total Finder 1.6.17 prevents Yosemite (10.10.2) shutting down but startup is ok.
When I disable Total Finder, it closes properly.
The console log says:
26.03.15 02:39:34,669 loginwindow[71]: Error: could not load nib file for DisconnectedFS plugin
This is the last record when I was desperatly trying to shutdown my Mac mini resulting in cutting power to switch it off.
Please help!

The issue could be related to Synology NAS and maybe their Finder integration plugin? (I tried to google for “DisconnectedFS plugin”.)

Or some people reported it could be related to mounted SMB drives.

Can you confirm?

The same thing has been happening to me for some time…

On one of my machines (a late-2011 MacBook Pro), if i select ‘Restart’ or ‘Shut Down’ from the Apple menu, it quits all of the running applications, as in a normal reboot, but then it simply stops.
The Dock is still accessible, but nothing else happens (i even tried to leave it for 3 hours, with no change)
In fact, i can launch Terminal (i have it in the Dock), then, in sudo mode, type reboot and it’ll finally reboot…

Note: i’ve compared the Console log of the machine in question with one that is not exhibiting the problem (a MacBook Pro 5,3), and i think i’ve found the culprit:

the application ‘Install in Progress’ seems to start as soon as i click ‘Restart’, but there are no updates to install…
I’m pretty sure that this is what is happening: for some reason, ‘Install in Progress’ seems to think that there are updates to run, and it just hangs there, and hangs the whole system with it…

I have tried clearing the caches (using the shareware Cocktail), to no avail…

If anyone can figure it out, please help! It is driving me nuts!!

PS: there are no other error messages in the logs, and i can find no log or preference file that is associated with the application ‘Install in Progress’ (itself located in /System/Library/CoreServices)
Also, the same exact thing happens in safe mode, except the Dock disappears…

I got this totally wrong…

I just figured out what the problem was:
For some reason, the internal update system in TotalFinder had stopped working, and it left an installer and some files in a folder located at:
~/Library/Application Support/TotalFinder/

All i did was trash this folder (and reinstalled TotalFinder from a downloaded .dmg for good measure), and the system is now restarting and shutting down correctly again…

i can’t believe i didn’t thin of that before, but for some reason, i didn’t think it was related to TotalFinder…