TotalFinder status under macOS 10.13 (High Sierra)

High Sierra didn’t bring any dramatic changes to

Latest TotalFinder version compatible with High Sierra is v1.10.2:

Thanks for testing.

Any news on an update to fix the High Sierra problem?
Just out of interest I looked at all of the other Finder replacements available and not one of them comes close to providing the functionality I love from Total Finder. Currently using two Finder windows but it just is not the same!!


Hi Jeff,

I didn’t have that much time to investigate all issues, but latest TotalFinder more or less runs under High Sierra. Only Coloured Labels feature crashes AFAIK.

I’m pretty positive that I will have fixes for it sometime next week.

So generally it is good news, the new Finder is very similar to Sierra version.

When I try to launch Tf it crashes and I get the crash dialogue - latest crash report is here:


Yes, your crash is in Labels “plugin”.

defaults write com.binaryage.totalfinder TotalFinderLabelsDisabled -bool YES

This will disable Color Labels plugin and TotalFinder should run next time you launch it.

To re-enable it again:

defaults delete com.binaryage.totalfinder TotalFinderLabelsDisabled

Brilliant! That fixed it…

Although Visor no longer works???

Visor initially worked for me. But after the first restart post 10.13 installation, it broke. Restarting Finder also appears to be broken with Visor enabled. Crash log:

I have just released initial version compatible with High Sierra on beta channel:

Please test it and report back.

Seems to run OK EXCEPT Visor does not appear (shot cut or via menu…)

Same goes in my testing. v. 1.9.6 seems to run well except for the Visor function. Thanks for churning out a version with High Sierra support so quickly! Let me know if I can test any builds with Visor capability. Happy to live dangerously for that feature. :slight_smile:

Hmm. Will have to investigate that Visor problem. It worked for me. Do you see any errors in the (hint: filter all messages by “Finder” keyword).

Yes, there are some entries in with TotalFinder in them. Which logs would you like specifically and from which folder?

I just meant in general if you could spot some error message or something fishy there (when trying to enable and activate Visor feature in preferences)

Restarted TF, set, unset, reset Visor - no entries in Console log and Visor still not working…

Same for me. I uninstalled TF, installed 1.9.3 then upgraded to 1.9.6, issue persists. TF works, but Visor does not. Now there are no errors in Console when enabling or disabling Visor either.

@darwin What settings do you have enabled? Maybe if I copy your settings exactly, I can get Visor to work?

I’m not sure if this should make a difference or not, but I was able to get Visor to work by changing the order in which I performed the actions:

  1. Uninstalling TF
  2. Reinstalling and updating TF
  3. Disabling SIP
  4. Enabling Visor
  5. Re-enabling SIP

The only difference for me was that in prior attempts I had enabled SIP and installed the helper, and then immediately rebooted and re-enabled SIP. This time I disabled SIP and then enabled Visor prior to rebooting to re-enable SIP.

This may have nothing to do with the fact that Visor is now working for me, but I thought I’d send it along just in case.

I have just released a new version. It looks like the Visor issues were caused by my recent changes. I introduced undefined behaviour. I’m still not 100% sure because I was unable to reproduce it here.

Thanks for your feedback:

Visor is currently working for me, but FYI - I cannot see any updates in TF. (including pre-release button is checked of course)