TotalFinder status under OS X 10.11 (El Capitan)


#42

I’m on OS X 10.11 10.11 Beta (15A225f)

I had to use the rootless command, and now all fine again. What an awesome Dev team and community!


#43

not working on 10.11 dp5


#44

I can also confirm that.


#45

Same here :- OS X 10.11 (15A236d) fails…


#46

It’s working still for me - did you guys boot into the recovery partition and “turn off system integrity protection”? Or use rootless=0?

I went down the recovery partition route, me, and everything that’s been working in the previous few previews is still working.


#47

I used the Rootless=0 route. So your saying boot in to system recovery and turn off SIP and all is Ok for you ?


#48

How come XtraFinder can still support tabs in 10.11?


#49

Do you have any link or evidence? I strongly believe XtraFinder has the same issue as TotalFinder. It won’t work with SIP enabled.


#50

I don’t think that’s true. You will still be able to do it with the nvram command line, which can use today in Yosemite (as well as previous OSX’s) to set other nvram parameters.

Not saying it’s ideal (it does still require a reboot), but it’s better than having to reboot twice, including once in Recovery mode.

Having a TotalFinder that only works in rootless mode is better than not having a TF at all.
Barring that, having a Finder replacement (e.g. PathFinder’ish) is better than not having an integrated TF.

Thanks for TF. I really don’t know why Apple refuses to do the “folders on top” thing.


#51

I can confirm that on El Capitan Public Beta 3 (which is more-or-less identical to DP5), TotalFinder 1.7.0 still works after either re-running the NVRAM command or disabling SIP in the 10.11 Recovery.


#52

I can confirm that since El Capitan Developer Beta 5 neither TotalFinder 1.7.0 nor XtraFinder (0.25.5) are working with disabled SIP.
I’m hoping for Beta 6 to solve the problem because working without TF is a PITA. I tried XtraFinder only to make sure it has the same problem. Never saw it working…


#53

I’ve tried multiple times with the command line, recovery partition SIP disable, combo of both, uninstall & reinstall TotalFinder and still get the Internal Error message and crash dialog. Is there something else I’m missing?
Exception Name: NSInvalidArgumentException
Description: -[TBrowserContainerController configureSidebar:setSplitterPosition:]: unrecognized selector sent to instance 0x7fd4793d5d80
User Info: (null)

0 CoreFoundation 0x00007fff96d7f9cc __exceptionPreprocess + 172
1 libobjc.A.dylib 0x00007fff9b8c4810 objc_exception_throw + 48
2 CoreFoundation 0x00007fff96d82a8d -[NSObject(NSObject) doesNotRecognizeSelector:] + 205
3 CoreFoundation 0x00007fff96cbc961 forwarding + 1009
4 CoreFoundation 0x00007fff96cbc4e8 _CF_forwarding_prep_0 + 120
5 TotalFinder 0x000000010eb7e59e TotalFinder + 132510
6 libdispatch.dylib 0x00007fff8d8675b1 _dispatch_call_block_and_release + 12
7 libdispatch.dylib 0x00007fff8d8633f1 _dispatch_client_callout + 8
8 libdispatch.dylib 0x00007fff8d87610a _dispatch_after_timer_callback + 77
9 libdispatch.dylib 0x00007fff8d8633f1 _dispatch_client_callout + 8
10 libdispatch.dylib 0x00007fff8d8710c8 _dispatch_source_latch_and_call + 2235
11 libdispatch.dylib 0x00007fff8d868a1d _dispatch_source_invoke + 937
12 libdispatch.dylib 0x00007fff8d8746bf _dispatch_main_queue_callback_4CF + 422
13 CoreFoundation 0x00007fff96cc70b9 CFRUNLOOP_IS_SERVICING_THE_MAIN_DISPATCH_QUEUE + 9
14 CoreFoundation 0x00007fff96c8289d __CFRunLoopRun + 1949
15 CoreFoundation 0x00007fff96c81e98 CFRunLoopRunSpecific + 296
16 HIToolbox 0x00007fff92c73675 RunCurrentEventLoopInMode + 235
17 HIToolbox 0x00007fff92c7340b ReceiveNextEventCommon + 432
18 HIToolbox 0x00007fff92c7324b _BlockUntilNextEventMatchingListInModeWithFilter + 71
19 AppKit 0x00007fff8bddd60f _DPSNextEvent + 1076
20 AppKit 0x00007fff8c1aae9c -[NSApplication _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 423
21 Tabs 0x0000000113500b24 Tabs + 68388
22 AppKit 0x00007fff8bdd349a -[NSApplication run] + 682
23 AppKit 0x00007fff8bd55522 NSApplicationMain + 1176
24 Finder 0x000000010b81985e Finder + 22622
25 libdyld.dylib 0x00007fff99b9e5ad start + 1
26 ??? 0x0000000000000001 0x0 + 1


#54

On beta 5 (and now 6) I get 'Troubles launching TotalFinder Apple Events cannot be delivered"


#55

I have a gut feeling that when 10.11 is released total finder might start working again. If I were developing a complex system like this I would disable ALL add ons and especially injection type - just sayin.


#56

I can confirm that 1.70 isn’t working under DP5 and now DP6 with sudo nvram boot-args=‘rootless=0’. I get “Troubles launching TotalFinder Apple Events cannot be delivered” as well as jmaynard.


#57

I’m not sure if this is of any help, but the developers of Bartender have a work around for their own software here:
http://www.macbartender.com/system-item-setup/

It installs a “System component” whilst System Integrity Protection is disabled and allows Bartender to fully function once re-enabled.

Hopefully whatever this “System component” is or does could be replicated to allow the same behaviour for TotalFinder.


#58

I can confirm that following the Bartender link (http://www.macbartender.com/system-item-setup/) results in TotalFinder working again. I am running El Capitan DP 5 - TF was working in DP4, but this last upgrade broke it as noted by other users. Seems a bit of a cat and mouse game at the moment - but it is encouraging that TotalFinder can be made operational more often than not between previews…


#59

If you follow the complete instructions of the Bartender link, it says you can re-enable SIP after installing the system-component.
I can confirm that Bartender still works after that but TotalFinder as well as Xtrafinder don’t!

I can also confirm, that if you only disable SIP in the recovery mode, both apps work. But in this case system integrity isn’t protected anymore…
So everybody should really know what he/she does!

I would prefer a solution like the one from the Bartender guys because it works with SIP enabled afterwards. I think this should be possible with TF and Xtrafinder. Will those 3 developers communicate to help each other???


#60

Running El Capitan beta 6 and used the info in the Bartender link (in earlier post in this thread) and TotlFinder now works (inc Visor). Only issue I noticed is no option to list folders first …


#61

@jmaynard: If you re-enabled SIP (system integrity protection) afterwards as it is written in the Bartender-post - what did you do to make TotalFinder work anyway? Because the new systemfile from Bartender only activates the Bartender.app in the SIP-system.
Is SIP really enabled on your Mac?