TotalSpaces automatically switches to other Space because program in said space is doing something

I’m on OSX Mavericks 10.9.2 with TS2 2.1.10. I currently have just 2 desktops and have assigned Word 2011 to Desktop 2.
I’ve made an Automator Workflow which opens a Word document, saves it as PDF and deletes the document. If I apply that workflow on a selection of Word documents, Word keeps popping up for every file.
The problem with this, is that TotalSpaces automatically switches from Monitor 1 to Monitor 2 (the space of Word), because “something’s happening there”. Really annoying, it shouldn’t be like this.

In Mission Control I’ve deselected all options, but with no luck. How can I fix this problem?

I was able to suppress this behavior by the following setting:

in Terminal: defaults write workspaces-auto-swoosh -boolean NO
then, in Terminal: killall Dock

Shouldn’t this setting be an option from within TotalSpaces2?

Ok good you found that. I’m not sure if we can replicate this setting in TotalSpaces2, but it’s worth looking into.