TotalSpaces support on MacOS 10.15 Catalina

Many thx Stephen !

Not at the moment, but thanks for asking! We might consider something like that in the future.

1 Like

Hi Stephen, I’ve been trying to install that 280 version on macOS Catalina public preview 1, without success. TS2 can’t install components message.
Is there a trick to get it done? SIP is indeed disabled.
Thx for your insight ?
Best, C

Stephen, I have installed and run successfully TotalFinder 1.12.0 on Catalina, but TotalSpaces2 2.8 fails with this message: “TotalSpaces2 failed to install correctly. Please try again or contact support. Error moving OSAX into place”.
If it’s useful, in another computer still running Mojave both newer versions of TotalFinder and TotalSpaces2 work perfectly well.
Is there something I can do to force TotalSpaces to run in Catalina OS? Thank you.

Hi Stephen,
I was able to install TS2 on macOS Catalina beta 3 (released yesterday night).

  • I can’t add desktops (tried several number sets)
  • I was wondering why the app wants to control the keyboard ?
    It looks like TS2 will be able to work after a few tweaks from your side ?
    Best. C

It’s indeed probably pretty small tweaks. Adding desktops was broken in beta 2 I think, but nobody noticed :slight_smile:

Oh, and regarding the installation issue, I should have a fix for that too.

Please try

There are a few changes around loading and such that could still have bugs, please let me know if it works ok.

Oh, one other thing I forgot to answer - the app needs the keyboard permission so that the global hotkeys can work.

Thank you, Stephen, for the effort. Unfortunately 2.8.1 doesn’t work either, although the error message is slightly different: “TotalSpaces2 failed to install correctly. Please try again or contact support. OSAX not found in; it might be damaged”. Previously it was that OSAX couldn’t be moved into place, now that it cannot be found. Hope this is useful. Cheers!

I’ll investigate that, thanks.

Had same issues here, with same error messages. Couldn’t get 2.8.1 to work at all, but 2.8.0 seems to work fine now when combining the tips from the other thread.

In short:

  1. make sure that SIP is off.
    Unlike before, this still does not mount protected parts of the file system into read-write mode by default. So there is one more step.

  2. Run: sudo mount -uw /
    This will remount your filesystem with write permissions until restart. This should allow TotalSpaces (and any other relevant app) to install things into /system or wherever else SIP protects.

Credit goes to @sercos

1 Like

I just uploaded v2.8.2

This should fix the various issues and should work with catalina beta 5. Please let me know how it goes if you try it.


Stephen, well done! Everything works now.

You got my Upvote.
Shame though that we have to go this way to install an App.
Terminal is not really an App for most people, even though it’s actually not that hard to copy and paste a terminal command.
If it was just that, even sadder is that SIP must be off, that’s not an easy task for most people.

Pretty sure a script could run when you install an App to mount the disk as read/write, not to sure if that would be possible for turning off SIP.

On a fresh install 2.8.4 does not work. It installs fine but cannot start. The notification asks me to enable automation in security & privacy preferences but TotalSpaces2 is not listed. I am using the trial version, as I do not want to spend money until I can see it working.

Thanks for the report, it looks like there was an error in the build of this version meaning it would not install correctly if it had not previously been installed: Please try


2.8.5 is working as expected. Seems if one had a lot of screens with alot of spaces … you had to goto MIssion Control … hold option … and delete the excess to get it below 16 … the max for Total Spaces.

Very weird. 2.8.5 working on my MacBook Pro but not my iMac as of this morning. Both using Catalina.

Emailed my console logs as well.