TotalSpaces v2.1.10 loses swipe-to-change on external display change

When I attach or detach an external monitor, TotalSpaces often stops recognizing the swipe-to-change-spaces shortcuts. (Swiping left and right with 3 fingers changes spaces using the system-default animations and horizontal-only spaces, swiping up and down shows mission control and expose, also system functions)

Easy enough to fix, I just uncheck and then recheck the box for “Swipe to change space”. Inconvenient, though.

If it changes anything, I use 3 fingers to swipe.



Yes, this happened to me yesterday. I am using a magic trackpad with a new iMac in Mavericks. Any change on the system preferences / trackpad seems to correct the issue. I changed my settings to 4 fingers to change monitors / 2 fingers to swipe individual windows. It was freaking me out for a few minutes however…

Hi, I have been trying to think how attaching or detaching the monitor could affect the swiping.

When you change the monitor, do you also use an external keyboard / mouse / trackpad?

Yes, in both cases (using the monitor, and not using the monitor), I use an external mouse and keyboard. The reason I switch between is because I use the external monitor while sitting, and use only the laptop when standing. In both cases I use a magic trackpad, and a wired keyboard while sitting, and a bluetooth Apple keyboard while standing.

I’ve done some experiments with this, and I do see some problems when the lid is closed due to the internal trackpad remaining active.

I have a potential fix for this. Please could you try this version and let me know if it helps?

Thanks, I will test tomorrow. I can’t reproduce it every time, but it’s common enough that if it doesn’t pop up for a day or two, we can assume it’s fixed.

Installed, will keep you posted on the results.

I should note, that in both my standing and sitting setups, the laptop remains open. (Use it as a second screen while sitting, use it as the primary screen while standing. I don’t use the internal trackpad in either case)

Bug happened this morning. Not 100% sure I restarted TotalSpaces after installing your linked version, so I restarted it (which made swiping start working again, as expected), and will report whether it happens again. But we may not have squashed the bug yet.

I was hopeful because I did also add code to restart the swipe detection when the monitor configuration changes.

Keep me informed, if you still see the problem then I’ll try to figure out why.

Yep, happened again. To elaborate, I slept my laptop while it was in my “sitting” configuration, connected to the external monitor at the end of my day yesterday. I did not use the laptop at all last night. This morning I came in and opened the laptop in my standing configuration (no external monitor), and swiping with three fingers was just doing the system spaces switching (horizontal). Disabling and re-enabling in preferences fixed the issue, as usual.

So it’s possible that sleeping in one configuration and waking in a different configuration could be causing the issue.

Again, not a huge issue, just a minor annoyance. The app is a lifesaver otherwise, thank you!

Yes, it seems likely that the re-configuration of the trackpad is not getting done correctly in that exact circumstance. I will investigate a fix.