TotalSpaces2 desktop navigation stops


#1

I am using TotalSpaces 2.3.9 under OS 10.10.5. Navigation with four-finger gesture between desktops stops responding quite often (happens to me a couple time per day) and then TotalSpaces needs to be restarted. it would not be a big deal, but it brings to the front all minimized windows, sometimes (always?) changing the desktop on which they were open. Any fixes?

Thanks

BTW, I also use Stay.


#2

I’m curious, did you disable the same swipe gesture from being used in System Preferences > Trackpad?

Let’s see if there’s more information about this issue in the Console:
http://binaryage.clarify-it.com/d/meeryk


#3

No, I have not disabled anything. It works for many hours than it stops. And the patterns repeats.

thnx


#4

Happens to me, too, ever since I got a new iMac. This didn’t happen on my old Mac which also ran El-Capitan. Four-finger swipe just suddenly starts doing whatever three-finger swipe is set to do in the Trackpad settings. And there is no four-finger setting in the system preferences, so it shouldn’t do that.

The TotalSpaces app continues to work as usual, only the swiping stops. If I quit TotalSpaces and start it again, it works again - until it fails again.

There is nothing in Console relating to the dock, except for the usual messages when stopping and starting TotalSpaces.


#5

that exactly what happens to me!

Restarting TotalSpaces app is a bit of an issue b/c it always opens all app windows that I have minimized and sometimes messes up their location (the desktop their were open on)


#6

Thanks for all the reports. Can everyone tell me what hardware they’re using? I don’t have one of the new Magic Trackpads yet, nor a Mac with the force-touch trackpad, so I’m curious if it’s hardware related.


#7

Could be. The Mac came with Magic Trackpad 2 (well, I ordered it that way :wink:), and with the old Mac I have been using the old Magic Trackpad.

I still have the old Magic Trackpad. I can try using it instead of the new one for a few days and see if the problem remains or not (it happens about once a day in my case, so it’ll take time to be sure).

BTW if you’re planning on buying Magic Trackpad 2 make sure your Mac supports it as it requires BlueTooth 4 - which may also be the problem. I can also try to use the new trackpad while it’s connected with the lightning cable instead of Bluetooth for a few days.


#8

MacBook Pro 15" mid 2015 (trackpad has the “force click” - which I disabled)


#9

That would be great! Make sure the other Trackpad is completely off and doesn’t interfere with the test (even take it to home/work just to make sure).


#10

I haven’t had a chance to test it over a long period yet, but I have something to report nontheless. It seems that indeed the problem is with the new trackpad. I noticed that if I disconnect it, turn it off and on, or connect it to the lightning cable, it immediately causes TotalSpaces to fail to swipe .

Meanwhile, I connected the old trackpad to the Mac, and totalspaces swipes with it, even if I turn it off, or even just pull the batteries out without gracefully turning it off first - as soon as I connect it back again, that is.

The two trackpads work side by side, the old one swipes, the new one swipes until it is disconnected, and then only the old one continues to swipe.


#11

Any more news on your test? I haven’t purchased a force-touch trackpad yet, but all signs point to it.

I have an issue in one of my other apps where “tap to click” doesn’t register clicks on menu bar icons, but only for force-touch trackpads, so this hardware is being treated differently at the system level.


#12

This was a bit of a long experiment, but here are the results:

I tested for about a week with both the old and new trackpads together, and everything worked well.

I tested with the old trackpad on its own, and all was well.

I then went back to the new trackpad on its own. As soon as I connected it, TotalSpaces stopped receiving the four-finger drag event. I restarted TotalSpaces, and then for about a week it seemed to work well, and suddenly there was a short break in communication between the trackpad and the Mac, and TotalSpaces immediately stopped receiving the event.

An interesting note: at this point I did not restart TotalSpaces, but I turned on the old trackpad to make sure that it worked. And as soon as I did that, TotalSpaces started receiving the event from both trackpads, and continued receiving the event from the new trackpad when I switched the old off again.

Now, go figure…:slight_smile:


#13

I keep having the exact same problem. Is there any fix yet?

BTW you don’t need to restart TotalSpaces. All you need to do is to deactivate/activate the swipe setting in TotalSpaces. At least this is what I do.


#14

I’m having this issue with the latest version of TotalSpaces on the latest version of Sierra (27" iMac) using the MagicPad. After waking, the four-finger swipe no longer activates TotalSpaces but the suggestion above about deactivating/reactivating the preference does the trick.

Was this ever looked into further? Thanks!


#15

Bump?


#16

I am having this issue as well with the 2017 iMac and the Magic Trackpad. I used to be able to toggle the 4 finger swipe and it would start working. But know it doesn’t work at all.