TotalSpaces2 inop on Mac OS 10.10 with recent update 2.4.6

Hi Steve,

I am still running Yosemite, and after updating to 2.4.6 yesterday, none of the TotalSpaces2 features seem to work. Transitions and “Mission Control” have all returned to stock behavior, and the TotalSpaces2 menu icon has no number in it.

I have tried restarting the computer and quitting/reopening TotalSpaces2, none of which have resolved the issue.

Please let me know if there is anything I can do to help diagnose this issue, such as running a debug build.


Sorry, we’re working on that. In the meantime:

  1. Quit TotalSpaces.
  2. In the Finder menu, choose Go > Go to Folder… (⇧⌘G)
  3. Enter /Library/ScriptingAdditions and click Go.
  4. Drag TotalSpaces.osax to the Trash (you will be asked to authenticate).
  5. Download and re-install version 2.3.11 from here:


I had the same problem in Mavericks (10.9.5), and the downgrade process fixed it. My preferences were only slightly munged.

Same issue. Downgrade fixed it.

I think the workaround is ok but does not survive a restart.
One would have to de-install, then run TotalSpaces, authorize with password, recreate Desktops via preferences.

Today’s update (2.4.8) seems to have fixed the issue.

Thank you for the quick turn around!